If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail not marked as read when also deleted

RESOLVED WORKSFORME

Status

MailNews Core
Filters
--
minor
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Christian Ertl, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I have a filter for mails starting with "*****SPAM*****" with the actions
deleting and marking as read.

Marking as read is only done when I use "move to folder: trash in (...)", it
doesn't work when "delete message" is set.

Comment 1

13 years ago
Which program are you using, and which version?

See bug 243832 and bug 201917, which are both about the same problem and which 
have been fixed for over a month.


> it doesn't work when "delete message" is set.

What is that supposed to mean?  There are three options for how to handle 
deleted messages under IMAP, but none of them are called "delete message."


Incidentally, if you use the "delete" action in a filter, "mark as read" is 
implied; you shouldn't need to specify both.
(Reporter)

Comment 2

13 years ago
> What is that supposed to mean?

You're right, I'm using the German language pack and translated it.

And it doesn't occur anymore.
Probably I added this to my personal "open a bug report list" with 0.9 and
because I didn't update immediately, the date was after the 1.0 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 3

13 years ago
Nothing in Mozilla was broken or fixed.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 years ago
It was broken and already fixed in 1.0.

Updated

13 years ago
Version: 1.0 Branch → 1.7 Branch
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.