css files not correctly loaded

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: eat_my_shortz, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Hi,

i use firefox since his fist release, but in this time there was no update 
which fixed this bug....

i have a w3c conform css stylesheet an in opara an IE6 it is correctly loaded 
and the page works, but with firefox i have several problems.

for example, dimension data are not correctly displayed, the scrollbar is not 
working (i do not mean an colored scrollbar, i mean the scrollbar itself is not 
there!)
a php loop which lists some data in several boxes does not become its border, 
the borders are all on the first box instead 

there are many more, but i don't know why mozilla/firefox doesn'n support css 
correctly

I hope u'll find the bug i mean

sincerely yours
eMs

Comment 1

14 years ago
Without an URL, it's difficult to see what's going on.

But the most common problem is that the css-file doesn't have the right
MIME-type : it should be text/css. Firefox will refuse a file sent with
text/plain for example. If this happens, you can see an error in the JavaScript
Console (Tools menu).
(Reporter)

Comment 2

14 years ago
oh sorry...

u can find the problem here
http://ems.em.funpic.de/index3.php

and it is not the problem u mean, i used the right MIME-type (text/css) but
firefox wont read it correctly.....

offline i got a new problem, firefox kills all scrolling, i mean, the scollbar
is not there...
IN IE i can use all scrollbars when they should be there....

Comment 3

14 years ago
Another example:  

Visit http://rant.netfirms.com/Adam/04/1219.htm in any other major browser to 
see how it's supposed to look, and then visit it in mozilla firefox.  Firefox 
completely ignores all of my font settings set through CSS.  The text appears 
black instead of the alternating blue and red.  This has been an issue at least 
since version .9.  

Another annoying problem, though far less critical, is that CSS cannot alter 
the color of the scroll bar.  For an example on that, visit 
www.livejournal.com/~bruised_skies/ in Internet Explorer and then visit in in 
Firefox.  Pay attention to the difference of the scroll bar.  It's a minor 
problem, but an annoying one, still.  This has been a problem since version .1.

These are both problems on all versions of windows on several completely 
distinct hardware configurations.

Comment 4

13 years ago
This may be related to a bug in some web servers.   My pages worked fine when
loaded from files, but when servered by Server: Apache/1.3.33 (Unix)\r\n
the stylesheets were Content-Type: text/plain\r\n after the first load.

The problem did not happen until I restarted the browser, enen though I cleared
caches.

looks like it could be: http://issues.apache.org/bugzilla/show_bug.cgi?id=30278

I could provide more information if that would be useful.

Comment 5

13 years ago
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fems.em.funpic.de%2Fclass_fire.css&usermedium=all

From Firefox's JavaScript Console
Error: Error in parsing value for property 'position'.  Declaration dropped.
Source File: http://ems.em.funpic.de/class_fire.css
Line: 124

Error: Error in parsing value for property 'float'.  Declaration dropped.
Source File: http://ems.em.funpic.de/class_fire.css
Line: 208

Colored scroll bars is Bug 77790, also in Mozilla Firefox the scroll bar will
not be displayed if the page does not need one see http://google.com

Comment 6

13 years ago
This problem occurs when DOCTYPE  is defined as:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

If not defined at all, firefox will give a warning instead of an error and load
the stylesheet.

I have not tried other DOCTYPEs

Comment 7

13 years ago
(In reply to comment #3)
Your stylesheet doesn't work because it's not valid.  Here's the output from the
W3C CSS Validator:

http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Frant.netfirms.com%2FAdam%2F04%2F1219.htm&usermedium=all

    * Line: 4
      Parse error - Unrecognized : .1 {color: #cc0000}
    * Line: 5
      Parse error - Unrecognized : .2 {color: #0000cc}

You violated two rules:
1. You need to put style information inside the HEAD element.
2. You cannot begin a CSS element with a number (See section
http://www.w3.org/TR/CSS21/syndata.html#q6).

Without further input, I would say this bug should be marked WORKSFORME.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.