Can we please rename NS_ADDRBOOKSESSION_CONTRACTID and "@mozilla.org/addressbook/services/session;1"

RESOLVED INVALID

Status

SeaMonkey
MailNews: Address Book & Contacts
P5
minor
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: timeless, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
here's the definition:
140 #define NS_ADDRBOOKSESSION_CONTRACTID \
141   "@mozilla.org/addressbook/services/session;1"

"session" to me means the item isn't a singleton. but it's always used with
getService.
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
(In reply to comment #0)
> here's the definition:
> 140 #define NS_ADDRBOOKSESSION_CONTRACTID \
> 141   "@mozilla.org/addressbook/services/session;1"
> 
> "session" to me means the item isn't a singleton. but it's always used with
> getService.

This now no longer exists :-) (except an old reference to it in code which currently isn't compiled) So therefore marking this bug as invalid.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.