lightstone.co.jp - unclosed entities

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Japanese
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Hideo Fujii, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

&YEN does not show the Japanese currency symbol.
Please try the following site. It shows "&Yen", but IE shows the currency sign.
http://www.lightstone.co.jp/products/origin/origin75/price75.htm

Reproducible: Always

Steps to Reproduce:
1. View http://www.lightstone.co.jp/products/origin/origin75/price75.htm

Actual Results:  
You see "&yen, but IE shows the Japanese currency symbol

Expected Results:  
It should show the Japanese currency symbol.
There is a missing ; after each &yen in the given url.
Assignee: bugs → japanese
Status: UNCONFIRMED → NEW
Component: View Source → Japanese
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: firefox.view-source → japanese
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> There is a missing ; after each &yen in the given url.

However, the following code (from local file) also does not work:
<HTML>
<BODY>
Yen with SEMICOLON:  &YEN;1000<br>
Yen with COMMA: &YEN,1000<br>
Yen with COLON:  &YEN:1000<br>
Yen with PERIOD:  &YEN,1000<br>
Yen with NOTHING:  &YEN1000<br>
</BODY>
</HTML>
=================================
Character entity references are case-sensitive (e.g. &Acirc; is a capital A with
a circumflex, &acirc; is a lower-case a with a circumflex): all of those
examples except the third and last (because both colon and numbers are legal
HTML NAME characters) will work with yen rather than YEN, none will work with
YEN even in IE.
Summary: &YEN does not show the Japanese currency symbol → lightstone.co.jp - unclosed entities
(Reporter)

Comment 4

14 years ago
Thank you VERY MUCH for pointing my misunderstanding. You're completely right.
&yen in lower cases works. By the way, it is very good lesson to tell that IE is
so loosly work even without ; like in this specific case... I like firefox. I
close this thread.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
reporter: instead of closing this, would you please help us by contacting the
web site?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> reporter: instead of closing this, would you please help us by contacting the
> web site?

Yes, I have told the site manager, and he has already updated the page. Now,
Firefox displays &yen correctly there.

Comment 7

14 years ago
yep, the pointed page has ';' after &yen. 

should close this bug as FIXED, not INVALID, because this is an Evangelism Bug.
(Reporter)

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> should close this bug as FIXED, not INVALID, because this is an Evangelism Bug.

Done. THANX A LOT.

Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.