Closed Bug 275450 Opened 15 years ago Closed 15 years ago

TITLE attribute in ANCHOR tag fails to render \n or \r\n properly

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 67127

People

(Reporter: lonestarinthesky, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0


Look at this HTML page fragment

<HTML>
<BODY>
<script Language='JavaScript'>
document.writeln("<A href='http://www.yahoo.com' title='This is line1" + "\n" +
"This is line2'>Link to yahoo. look at tooltip</a>");
document.writeln("<p/><A href='http://www.yahoo.com' title='This is line1" +
"\r\n" + "This is line2'>Link to yahoo. look at tooltip</a>");
</script>
</BODY>
</HTML>

I would expect that the tooltip text should honor the new-line characters. 

In IE, either with \r\n or \n this displays as expected:
"This is Line1
 This is Line2"

in firefox, the tooltip is displayed as :

"This is Line1[ascii char for carriage-return][ascii char for line feed]This is
Line2"

"This is Line1[ascii char for line feed]This is Line2"

Depending on whether or not a [CR] was present.

Reproducible: Always

Steps to Reproduce:
1. Load example script
2. Hover mouse over the ANCHOR
3. Wait for tool tip to appear
4. Notice embedded ASCII characters instead of actual LINEFEED

Actual Results:  
See details

Expected Results:  
See details.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.