Results from LDAP queries populates more than one window

RESOLVED DUPLICATE of bug 135231

Status

RESOLVED DUPLICATE of bug 135231
14 years ago
10 years ago

People

(Reporter: jezza, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; INTRANETUSER)
Build Identifier: 

I have the 'Address Book' open (Window > Address Book) and the 'Select 
Addresses' window open (Compose > Options > Select Addresses...). On 
the 'Address Book' window, do a search for 'smith' (or some other name which 
will return results). Now go to the 'Select Addresses' window but keep 
the 'Address Book' open and in view (albeit in the background). Do a search 
for 'smith' or whatever you searched for before.

You'll notice that the results appear correct on the window that is currently 
selected, but the results to this window get duplicated to the 'Address Book' 
window in the background. You'll notice that if you switch these windows, the 
same thing occurs. Whilst I haven't tried, this might occur for other 
situations where LDAP results are shown.

It only works when you are searching for the same name.

Reproducible: Always

Steps to Reproduce:
1. Open Address Book (Window > Address Book)
2. Open Select Addresses (Compose > Options > Select Adddresses)
3. Search for 'smith' in Select Addresses. Keep this window open.
4. Search for 'smith' in Address Book.

Actual Results:  
The results to step 4 get added to the results found on step 3 (which means 
that get duplicated seeing as you have to be searching for the same string for 
this to occur).

Expected Results:  
The software should only have populated the screen which is topmost. Any other 
search results (albeit for the same search) should not be effected.

Updated

14 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Confirming with Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8b4) Gecko/20050913
SeaMonkey/1.0a. This is a weird problem.
Assignee: mail → nobody
Status: UNCONFIRMED → NEW
Component: Address Book → MailNews: Address Book
Ever confirmed: true
OS: Windows 2000 → All
Product: Mozilla Application Suite → Core
QA Contact: addressbook
Hardware: PC → All
Version: 1.7 Branch → Trunk
Just found out this is a duplicate of bug 135231

*** This bug has been marked as a duplicate of 135231 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.