Closed Bug 275487 Opened 15 years ago Closed 15 years ago

'Save As' non-functional in Page Info > Media Tab

Categories

(SeaMonkey :: Page Info, defect, minor)

1.7 Branch
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 239472

People

(Reporter: melen_cw, Assigned: db48x)

Details

The 'Save As' button on the Media Tab of the Mozilla 1.75 Browser 'View Page
Info' right mouse context menu appears to be broken.

Steps to reproduce:

1. Open any web page containing images
2. Right Mouse > Click 'View Page Info'
3. Select the 'Media' Tab on the context dialogue window.
4. Click on a image in the 'Address - Type'  list.
5. The image correctly displays in the 'preview' window at the bottom of the
dialogue
6. Hit the 'Save As' button immediately above the preview window
7. A 'Save Image' file save dialogue is presented
8. Either accept the default offered filename and path or change it (makes no
difference)
9. Hit 'Save' to dismiss the dialogue

10. NO IMAGE is saved :-(

This function was fully functional in Moz 1.70, but I discovered that in no
longer works in Moz 1.73 and i have just upgraded to Moz 1.75 - still doesn't
work :-(

Calvin.
Hi,

Just thought to have a look at what was actually happening in the underlying OS
file system level when this problem arises. Here is the capture from Mark
Russinovich's 'FileMon', showing what happens at file system level when you hit
the 'Save' button:

20	14:52:11.163	mozilla.exe:184	OPEN	J:\	SUCCESS	Options: Open Directory 
Access: Traverse	
21	14:52:15.479	mozilla.exe:184	OPEN	J:\160x600_INV.gif	FILE NOT FOUND	Options:
Open Directory  Access: Traverse	
22	14:52:15.479	mozilla.exe:184	OPEN	J:\160x600_INV.gif	FILE NOT FOUND	Options:
Open Directory  Access: Traverse	
23	14:52:15.479	mozilla.exe:184	OPEN	J:\160x600_INV.gif	FILE NOT FOUND	Options:
Open  Access: All	
24	14:52:15.479	mozilla.exe:184	CREATE	J:\160x600_INV.gif	SUCCESS	Options:
OverwriteIf  Access: All	
25	14:52:15.479	mozilla.exe:184	CLOSE	J:\160x600_INV.gif	SUCCESS		
26	14:52:15.479	mozilla.exe:184	OPEN	J:\160x600_INV.gif	SUCCESS	Options: Open 
Access: Delete	
27	14:52:15.479	mozilla.exe:184	DELETE 	J:\160x600_INV.gif	SUCCESS		
28	14:52:15.479	mozilla.exe:184	CLOSE	J:\160x600_INV.gif	SUCCESS		
29	14:52:15.479	mozilla.exe:184	OPEN	J:\	SUCCESS	Options: Open Directory 
Access: All	
30	14:52:15.479	mozilla.exe:184	DIRECTORY	J:\	NO SUCH FILE
FileBothDirectoryInformation: 160x600_INV.gif	
31	14:52:15.479	mozilla.exe:184	CLOSE	J:\	SUCCESS		

Basically, it creates the requested filename, saves the file, then promptly
turns around and deletes it again !!

Calvin.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040618
The bug is present here, too.
for all Hardware/OS, see comment 2 and bug 239472 comment 50
OS: Windows NT → All
Hardware: PC → All
this is most likely a duplicate of bug 239472, but it appears that fix was never
committed.
it is a dup. the fix isn't in 1.7.5 because it was never applied to that branch.
it's fixed for 1.8 (which is in alpha right now), and I'll check it in to 1.7.6
if they give me a= for it.

*** This bug has been marked as a duplicate of 239472 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.