"Save to" dialog doesn't appear when downloading files.

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: melop_cui, Assigned: kveton)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
USER-AGENT:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20041220 Firefox/1.0+

When downloading files with the extension of ".XPI" (the extension file for
mozilla products) by entering the url in the location bar or clicking a link,
the file will be renderred as text file in the browser window instead of showing an
"Save to" dialog to ask the user where to save them.

This issue may due to an incorrect header sent by the server. In Internet
Exploer 6.0 with WinXP SP2, the "MIME-Sniffer" detected it as a "zip" file.
(Reporter)

Comment 1

14 years ago
Created attachment 169274 [details]
When try to download an xpi file, content of file is displayed in the browser

Comment 2

14 years ago
Probably this server was used:
http://216.165.129.134/pub/mozilla.org/extensions/aboutconfig/aboutconfig-0.4-tb.xpi
-->moving
Assignee: bugs → kveton
Component: Download Manager → FTP: Mirrors
Product: Firefox → mozilla.org
QA Contact: bmo → myk
Version: Trunk → other

Comment 3

14 years ago
Yeah, they need to send .xpi's as application/x-xpinstall. (wasn't there a plan
to require all mirrors to have the correct types? heh.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

14 years ago
All of the hosts in ftp.mozilla.org rotation are reporting the correct mime-type
now for .xpi files.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.