Freeze when trying to download/delete large IMAP messages

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: david, Assigned: mscott)

Tracking

({hang})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 1.0 (20041206)

On first launching Thunderbird, it begins to download mail (over SSL) from
several of my IMAP accounts. I am able to read the messages except when I click
on a large message (file size was about 800Kb this morning). At this stage, the
mail view window freezes on the last message viewed even if I click on another
message. I can still click on messages but nothing actually works.

I exit TB and then relaunch it but it doesn't fully launch. The taskbar icon is
there but the screen is just white with the top title bar there also. I have to
terminate the process through Task Manager and then load it for a 3rd time
before it works without any problems.

Reproducible: Always

Steps to Reproduce:
1. Have a text large message (not with an attachment) about 800Kb sent to you
2. Download it via IMAP over SSL
3. Click to view a smaller message
3. Click the large message and it will freeze

Actual Results:  
The window freezes on the last message

Expected Results:  
Loaded the large message or at least shown a status bar showing it was
downloading it

Using default theme.

Updated

14 years ago
Keywords: hang
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.1+
(Assignee)

Comment 1

14 years ago
approving bugs is only allowed by the bug triage folks. Please don't plus bugs
or you'll lose your bugzilla privleges.
Flags: blocking-aviary1.1+
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0

Comment 2

14 years ago
do you have any folders configured for offline use? How reproducible is this? If
it's reproducible, can you generate an imap protocol log by following these
instructions? Please e-mail me the log, or attach it here. thx.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 3

14 years ago
Created attachment 170749 [details]
Thunderbird log as requested in #2

As requested here is the IMAP log. I created a large file (92KB) using some
stock text and sent it to my david at ezoshosting.com account from my david at
mytton.net account. I opened my mail client and clicked on my david at
ezoshosting.com account inbox. The message started downloading and I clicked it
and hit delete. TB then froze. I waited a few moments to see if it continued -
it didn't. The only way to solve the problem was to terminate the process.

Note: I think this is related to bug 277591
(Reporter)

Comment 4

14 years ago
There are no offline folders configured and I can reproduce this almost every time.

Comment 5

14 years ago
Do you have the option set to delay marking messages read when you click on
them? That could definitely be involved. And are you compacting/expunging your
inbox? I see an expunge attempt in there, which is odd...
(Reporter)

Comment 6

14 years ago
> Do you have the option set to delay marking messages read when you click on
> them? That could definitely be involved. 

No. They are marked read as soon as I click them. The "Mark message read after x
seconds" option is not ticked.

> And are you compacting/expunging your
> inbox? I see an expunge attempt in there, which is odd...

It is set to Expunge on exit for all my accounts.

Comment 7

14 years ago
OK, if that's the whole log, I see part of the problem - your imap server is
never telling us that it's done fetching the message:

2752[2303f78]: 22fd1d0:houston.ezoshosting.com:S-INBOX:CreateNewLineFromSocket:
feugiat quis, fermentum vel, leo. Nulla nibh. Integer fermentum urna accumsan

that's the last thing we see in response to fetching that message. We should see
this at the end, like we do for the first message:

 Normal Message End Download Stream
2752[2303f78]: ReadNextLine [stream=2304318 nb=27 needmore=0]
2752[2303f78]: 22fd1d0:houston.ezoshosting.com:S-INBOX:CreateNewLineFromSocket:
17 OK UID FETCH completed

My guess is that this is a server bug, perhaps with ssl, but there are other
possibilities, like a virus checker corrupting the stream.
(Reporter)

Comment 8

14 years ago
I don't think it is the server that is the problem. I disabled my ZoneAlarm
Antivirus and Firewall and the problem seems to have gone - I couldn't replicate it.

I have uploaded at http://www.mytton.net/275521-no_firewall_logs.zip 2 log files
in a .zip. Log 1 is where everything is working fine with the same size message
that caused the hang I provided the original log file for. I then upped the
message size to 1.5mb of text and tried to reproduce it. Although it looked like
it had hung, it didn't actually - it was downloading the message from the server
(even though I'd hit Delete) and after about 35 seconds, it deleted it. During
this time, I could access any other part of TB and read other messages already
downloaded.

Therefore, I think you were right in that ZoneAlarm seems to be causing the
problem. I'll get onto their support and report the problem. Nevertheless, I
think it might be useful to have a status bar display - it looked as though it
had hung as there was no status bar saying it was downloading the message.

Comment 9

14 years ago
we do display a status bar message to that effect, but I suspect it's getting
cleared by some other operation.

I'm working on adding timeouts to the imap code, so eventually you would get
some sort of message, though it probably won't mention virus checkers...
(Reporter)

Comment 10

14 years ago
OK. So I suppose this can be closed as a problem with the ZoneAlarm firewall?

Comment 11

14 years ago
yes, wfm, thx
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.