crash when playing java game ( slot machine )

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
--
critical
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: JOHN THOMPSON, Assigned: roc)

Tracking

({crash, hang})

Trunk
x86
Windows XP
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
AFTER PLAYING A SHORT TIME BRINGS PC DOWN.  NOT SO ON OTHER BROWSERS.
Would you be so kind as to tell us which browser exactly you're using, and give
some more detail about the circumstances?
Assignee: justdave → general
Component: Bugzilla-General → General
Product: Bugzilla → Mozilla Application Suite
QA Contact: mattyt-bugzilla → general
Also, please turn off your caps lock.

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041219
Java(TM) 2 Platform Standard Edition 5.0  

complete hang of the computer, had to reset.

Steps to reproduce:
1. http://www.simslots.com/
2. Click on sixth macine in second row, the one marked 2x.
  I didn´t try others. Direct link: http://www.freeslots.com/Slot3.htm

3. Java comes up, slot machine is loaded. You´ve got 50 credits, bet one and
press start button. When machine has finished, start again.
I hung in the third cycle, no mouse movement, no CtrlAltDel, frozen.

Athlon XP1600+, Win98SE, 512 MB RAM, Open Office in the tray.




Severity: normal → critical
Keywords: hang
Summary: PC CRASHES → crash when playing java game ( slot machine )

Updated

13 years ago

Comment 4

13 years ago
Can reproduce the crash with: 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041221
Mnenhy/0.7 {Build ID: 2004122117}
Sun JRE 1.5.0

Have loaded the Site and clicked on the sixth machine in the second row like
described in Comment #3, Java RE starts to come up, Mozilla crashes immediatly
before the Game was loaded complete. Will try to get a Stack. 

Comment 5

13 years ago
O.k., got an Talkback ID: TB2688769Q

With Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041220
Mnenhy/0.7 {Build ID: 2004122005} i can play some rounds, but after playing
Mozilla crashes while leave the Site via Link from Personal Toolbar.

Comment 6

13 years ago
Incident ID: 2688769
Stack Signature	ntdll.dll + 0x4b3ad (0x778cb3ad) efd99714
Product ID	MozillaTrunk
Build ID	2004122005
Trigger Time	2004-12-21 22:11:34.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	ntdll.dll + (0004b3ad)
URL visited	
User Comments	Try to reproduce crash for Bug 275538 playing at
http://www.simslots.com/ and then go to another site from personal toolbar
Since Last Crash	361 sec
Total Uptime	361 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x4b3ad (0x778cb3ad)
ntdll.dll + 0x4c8d7 (0x778cc8d7)
MSVCRT.DLL + 0x1e00 (0x78001e00)
??3@YAXPAX@Z
nsBlender::`scalar deleting destructor'
nsBlender::Release 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/gfx/src/nsBlender.cpp,
line 59]
nsCOMPtr_base::~nsCOMPtr_base 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 82]
nsViewManager::~nsViewManager 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 555]
nsViewManager::`scalar deleting destructor'
nsViewManager::Release 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 555]
nsCOMPtr_base::~nsCOMPtr_base 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 82]
DocumentViewerImpl::~DocumentViewerImpl 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 537]
DocumentViewerImpl::Release 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 509]
nsCOMPtr_base::~nsCOMPtr_base 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 82]
nsCOMPtr_base::assign_from_qi 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsCOMPtr.cpp,
line 97]
PresShell::UnsuppressAndInvalidate 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 4661]
PresShell::UnsuppressPainting 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 4711]
PresShell::sPaintSuppressionCallback 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 2842]
nsTimerImpl::Fire 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 384]
PL_HandleEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 693]
PL_ProcessPendingEvents 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 631]
_md_EventReceiverProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 1434]
Assignee: general → roc
Component: General → Layout: View Rendering
Keywords: crash
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → Trunk

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050415
Talkback ID: TB5123776W

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050625
Java(TM) 2 Platform Standard Edition 5.0 Update 4

no crash, slotmachine is working, but I can´t close the tab. Changing to other
tabs is working, closing some other tab works too.

tested http://www.freeslots.com/Slot3.htm

Comment 9

13 years ago
Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050625
Java(TM) 2 Platform Standard Edition 5.0 Update 4

no crashes, but once only I couldn´t close the tab with the game, though I could
change to other tabs and these could be closed. All was working normally, but I
couldn´t close the tab.

tested http://www.freeslots.com/Slot3.htm

Comment 10

13 years ago
*** Bug 303772 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050901
Firefox/1.6a1 - Deer Park Alpha 2 - Windows XP, SP2

WFM, page loaded correctly - tested both links to reproduce bug, played game for
10 minutes each time, neither resulted in Firefox hanging or crashing.

Tab could be closed without problem.

Updated

11 years ago
Blocks: 353557

Updated

11 years ago
No longer blocks: 353557
QA Contact: ian → layout.view-rendering

Comment 12

8 years ago
WFM using: 
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090823 Mnenhy/0.7.5.20005.h5 SeaMonkey/2.0b2pre

with Suns current JRE 1.6.0_16 (6.0.160.1). 

Have tested on several Systems running WinXP SP3 and Win2k, also with the current Firefox-Trunk-Nightly-Build. Page load fine, playing without problems, no hang, no crash. So I will close this Bug now as WFM, according to c#11.

Feel free to reopen if you can reproduce the crash with current Builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.