unable to copy to fcc folder

VERIFIED DUPLICATE of bug 27460

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 27460
19 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

when I compose and send a message, it sends it, but fails to copy to fcc folder.

I get the alert that tells me the copy failed, and asks if I want to close the 
compose window.

I'll attach the stack trace to where the failure happens.
it fails on line 3897 of nsMsgSend.cpp

  while (! inputFile.eof())
	{
    if (!inputFile.readline(ibuffer, ibuffer_size))
    {
***   status = NS_ERROR_FAILURE;
      goto FAIL;
    }

nsMsgComposeAndSend::MimeDoFCC(nsFileSpec * 0x040b1980, int 0, const char * 
0x01f12730, const char * 0x040b4e10, const char * 0x040b27a0) line 3897
nsMsgComposeAndSend::DoFcc() line 2941 + 74 bytes
nsMsgComposeAndSend::DoDeliveryExitProcessing(unsigned int 0, int 0) line 2882 + 
8 bytes
nsMsgComposeAndSend::DeliverAsMailExit(nsIURI * 0x044f0d44, unsigned int 0) line 
2903
MailDeliveryCallback(nsIURI * 0x044f0d44, unsigned int 0, void * 0x046eb200) 
line 2539
nsMsgDeliveryListener::OnStopRunningUrl(nsMsgDeliveryListener * const 
0x044f05b0, nsIURI * 0x044f0d44, unsigned int 0) line 82 + 21 bytes
nsUrlListenerManager::BroadcastChange(nsIURI * 0x044f0d44, nsUrlNotifyType 
nsUrlNotifyStopRunning, unsigned int 0) line 97
nsUrlListenerManager::OnStopRunningUrl(nsUrlListenerManager * const 0x044f0d00, 
nsIMsgMailNewsUrl * 0x044f0d44, unsigned int 0) line 110 + 18 bytes
nsMsgMailNewsUrl::SetUrlState(nsMsgMailNewsUrl * const 0x044f0d44, int 0, 
unsigned int 0) line 105
nsSmtpProtocol::ProcessProtocolState(nsIURI * 0x044f0d44, nsIInputStream * 
0x044b62f8, unsigned int 312, unsigned int 36) line 1373
nsMsgProtocol::OnDataAvailable(nsMsgProtocol * const 0x044b7ac0, nsIChannel * 
0x044b6534, nsISupports * 0x044f0d44, nsIInputStream * 0x044b62f8, unsigned int 
312, unsigned int 36) line 172 + 32 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x046aff90) 
line 370
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x046a9f50) line 93 + 12 bytes
PL_HandleEvent(PLEvent * 0x046a9f50) line 526 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ce6d40) line 487 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000b0926, unsigned int 49361, unsigned int 0, 
long 13528384) line 975 + 9 bytes
USER32! 77e71820()
00ce6d40()

I'm trying to send a one line plain text message
it happens with an html compose message too.

my fcc pref looks correct.

Comment 3

19 years ago
This is a dupe of bug 27460, It hink.


*** This bug has been marked as a duplicate of 27460 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
I'll mark verified as duplicate.  The other bug is marked fixed now.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.