Some suggestions for Items on the Help Menu

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: bfowler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 2007-07-03)

(Reporter)

Description

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041222
Firefox/1.0+

Firefox version of the Camino Bug 167428 "add access points from
Help menu to release notes and readme (milestone-based)"

At present, the Help menu has items:

     [Help Contents][Promote Firefox][About Mozilla]

Examples of good help menus include Filemaker Pro

     [FileMaker Pro Help][Contents and Index][FileMaker on the Web][Send
Feedback to FileMaker][Register Now]

and BBEdit

     [BBEdit Help][BBEdit User Manual][Glossary Reference][Grep
Reference][Preferences][Search Reference][Bare Bones Software Web Site][Bare
Bones Software Tech Support][Register Your Copy of BBEdit][BBEdit Release
Notes][BBEdit Support FAQ Page][BBEdit Product Updates Page][BBEdit Developer
Info][Check for Update]

Now whilst there may be room for improvement on both of these, they do act
as pointers for what the Help Menu should contain.

I have not been able to find a Bug for suggesting items on the Help Menu, so
I am proposing to start this one, the idea being that people can add
their suggestions here.

     [Firefox Help Cmd-?]
     [Help Contents]
     [Firefox User Manual]
     
     [Firefox on the Web]
     [Firefox Mozillazine]
     [Firefox Support]

     [Searching the Web]
     [Finding Text on a Web Page]
     [Web Development Best Practices]
     [Troubleshooting your Internet Connection]

     [Firefox Release Notes]
     [Firefox FAQ]
     [Firefox Updates]

There are a few other things needed, but you will probably get the idea
of providing safe entry points into the Mozilla web site, access to
local documentation and simple guidance on using Firefox, and one simple,
appropriate way to seek support.

I would also suggest removing the link to 'Reporting Bugs' from the
http://www.mozilla.org/support/firefox/ page (my intended destination
for the sixth item on my list). There could be a new link created
to 'See Bugs Reported Today' which was on the Suite, and I liked
for its proof that the process of pushing Firefox forward is alive
and well; and in this context, the suggestion that Bugzilla should
be read rather than posted to.

If possible, it would be good to have links to Bugzilla (particularly
any that might encourage submitting simple requests as bugs) only from
pages marked as Developer Info. 

Nightlies and Debug builds should include such info or links (something
which was also in the Suite).

I have thinking on these lines for over a year, and I was hoping to
submit a complete patch to Camino (that project is Panther only); but
what stimulated me to post today was coming across this message
on Bug 275362 "'Report Issue' in Help menu", 

	Comment #2
	
	Bugzilla is a tool for the developers and it's no support database.
	A "normal" user wants support but support bug reports are invalid.
	A user must also read
	http://www.mozilla.org/quality/bug-writing-guidelines.html , 
	check for dupes et cetera before he reports a bug into bugzilla.
	
	Your bug report also shows that the bug reporting quality is not 
	very good: No Build ID/Version (such an entry could be already 
	added), wrong severity, wrong component.
	
	suggesting wontfix
	
which I suggest could be cleaned up (if necessary) and placed on either
a support page such as I one I mentioned above, or a Bugzilla page. I 
was looking for this text to paste into Bug 275037 "crash with webster.com 
site".

Getting Support Requests out of Bugzilla (in the sense of not getting them
in here in the first place) is really a two way process, see these articles
which may be a little elementary for the readership here: 
http://freshmeat.net/articles/view/149/ and 
http://freshmeat.net/articles/view/1082/

(I am not sure that there is yet a Mozilla Web Development Best Practices
Page anywhere on the Web, again it is something that I have felt the lack
of for many months, but there is one for Safari which reads as though
it was written by a Mozilla developer originally ...)

Comment 1

14 years ago
-> Menus.
Assignee: jwalden+fxhelp → firefox
Component: Help Viewer → Menus
QA Contact: firefox.help → bugzilla
Hardware: Macintosh → All

Comment 2

14 years ago
I think the comments that you have are basically good but there is a need to
ensure that the menus are maintained in some sort of reasonable and logical
order with not too many options that can be both confusing and make the menus
more difficult to navigate. 

If you are going to add new options (which I think is a good idea), they need to
be linked to from the help viewer, I think, rather than the main help menu
itself. At any rate, I would not include so many different options from the help
menu. 

Perhaps a few salient choices would be useful, such as:

[Help Contents]

[Firefox on the Web]
[Firefox Forums]

[Searching the Web]
[Troubleshooting your Internet Connection]

[Firefox FAQ]
[Firefox Updates]

I do especially think that the Troubleshooting your Internet Connection article
would be particularly useful and something that should definitely be given some
thought to.

Comment 3

14 years ago
I would further add that 'Help->Promote Firefox' is inappropriate and offensive.
 The help menu is where a user goes to GET help, not provide help.  I'm certain
there's someplace for 'Promote Firefox', but it's not in the Help menu.  I'd
suggest a likely spot for it would be in the 'About Firefox' dialog.

Updated

13 years ago
Assignee: firefox → nobody
QA Contact: bugzilla → menus
Version: Trunk → unspecified

Comment 4

12 years ago
Firefox 2.0.0.4 has Help→Release Notes, which “cover what's new, download  and installation instructions, known issues and frequently asked questions for Firefox 2.”
Though “Release Notes” may not be associated with FAQ etc for the user, are you satisfied with that item?

Also, the bug may be INVALID or WONTFIX.
Whiteboard: CLOSEME 2007-07-03
Given the substantial changes that have taken place in Firefox in the past two releases and the changes coming soon for Firefox 3, I think this bug is covered and INVALID. If you have specific menu additions you think will be helpful, please file each one as a new bug so that they can be evaluated individually.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.