crash on startup if no network connection; OT not initialized

VERIFIED DUPLICATE of bug 25321

Status

()

Core
Networking
P2
major
VERIFIED DUPLICATE of bug 25321
18 years ago
18 years ago

People

(Reporter: Kathleen Brade, Assigned: gordon)

Tracking

({crash})

Trunk
PowerPC
Mac System 8.5
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
I crash on startup if I don't have a network connection.  This is a huge
regression.  I think this should be fixed for beta1.

From what I can tell from a Mac stack crawl, I crashed in the destructor for
nsDNSService.  I'm guessing that the problem is a lack of a network connection
but it could also be due to OT not being initialized.  I can check that out in a
few minutes.
(Reporter)

Updated

18 years ago
Severity: normal → major
Keywords: beta1, crash
Priority: P3 → P2
(Reporter)

Comment 1

18 years ago
Based on additional testing, I'm guessing that the problem is a lack of OT
initialization.
Summary: crash on startup if no network connection (or uninit'd OT?) → crash on startup if no network connection; OT not initialized
(Assignee)

Comment 2

18 years ago
It should be pretty simple to make the calls to clean up Open Transport 
conditional on mServiceRef having been allocated.  If we couldn't initialize Open 
Transport for some reason, we should be closing it.  I recommend PDT+.  I could 
fix this tonight or Monday.
Status: NEW → ASSIGNED

Comment 3

18 years ago
-> gordon
Assignee: warren → gordon
Status: ASSIGNED → NEW
Target Milestone: M14

Comment 4

18 years ago
Putting on the PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Comment 5

18 years ago
Kathy, do you have to have no network connection from the time you boot the Mac?  
I tried unplugging the network, but I was able to launch and quit mozilla with no 
crash.  I'll put in the code to conditionally deallocate the OT service provider 
only when it has been allocated, but I would like to be able to reproduce the bug 
myself.  Any additional hints you can think of would be appreciated.
Status: NEW → ASSIGNED

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 25321 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.