If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View Cookies Dialog crashes on close. [@ HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)]

RESOLVED WORKSFORME

Status

Core Graveyard
Widget: Mac
--
critical
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Jesse Weinstein, Assigned: Josh Aas)

Tracking

({crash})

1.7 Branch
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
It is not possible to close the View Cookies Dialog via keyboard or buttons.  It
can only be closed by restarting the browser.

1. Open the View Cookies dialog from the Preferences.
2. Make some changes.
3. Try to close it.


One time, it crashed upon closing.  This created the following Talkback ID:
TB2627883Y
(Reporter)

Updated

13 years ago
OS: All → MacOS X

Comment 1

13 years ago
Incident ID: 2627883
Stack Signature	0x05929620 cfe88630
Product ID	Firefox10
Build ID	2004091322
Trigger Time	2004-12-18 15:03:04.0
Platform	MacOSX
Operating System	Darwin 7.6.0
Module	
URL visited	
User Comments	
Since Last Crash	438572 sec
Total Uptime	634403 sec
Trigger Reason	SIGILL: Illegal Instruction: (signal 4)
Source File, Line No.	N/A
Stack Trace 	
0x05929620
HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)
HIToolbox.145.0.0 + 0x66bc (0x927d66bc)
HIToolbox.145.0.0 + 0x4b12c (0x9281b12c)
CoreFoundation.299.32.0 + 0xcf8 (0x90190cf8)
nsMacWindow::~nsMacWindow() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacWindow.cpp,
line 253]
nsBaseWidget::Release() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/xpwidgets/nsBaseWidget.cpp,
line 63]
nsXULWindow::ShowModal() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpfe/appshell/src/nsXULWindow.cpp,
line 336]
nsWindowWatcher::OpenWindowJS() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 566]
GlobalWindowImpl::OpenInternal() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 1211]
GlobalWindowImpl::OpenDialog() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 3376]
_XPTC_InvokeByIndex()   XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode)() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2027]
XPC_WN_CallMethod() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 2976]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 1036]
JS_CallFunctionValue() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsapi.c, line
3705]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1299]
nsJSEventListener::HandleEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/events/nsJSEventListener.cpp,
line 177]
nsEventListenerManager::HandleEventSubType() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 710]
nsEventListenerManager::HandleEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1516]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2841]
MenuHelpersX::DispatchCommandTo() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMenuBarX.cpp,
line 65]
nsMenuBarX::CommandEventHandler() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMenuBarX.cpp,
line 331]
HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)
HIToolbox.145.0.0 + 0x223c (0x927d223c)
HIToolbox.145.0.0 + 0x58af0 (0x92828af0)
HIToolbox.145.0.0 + 0x52c60 (0x92822c60)
HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)
HIToolbox.145.0.0 + 0x223c (0x927d223c)
HIToolbox.145.0.0 + 0x146e4 (0x927e46e4)
HIToolbox.145.0.0 + 0x296dc (0x927f96dc)
HIToolbox.145.0.0 + 0xc189c (0x9289189c)
HIToolbox.145.0.0 + 0xc3478 (0x92893478)
HIToolbox.145.0.0 + 0x8d78c (0x9285d78c)
HIToolbox.145.0.0 + 0xb3b8c (0x92883b8c)
nsMacMessagePump::DoMouseDown() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 77]
nsMacMessagePump::DispatchEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 443]
nsMacMessagePump::DoMessagePump() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 312]
nsAppShell::Run() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsAppShell.cpp,
line 114]
xre_main() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 710]
_start()   start()

reporter: one problem per report ;-), not being able to close something and
crashing when closing it are two distinct problems. find/file a new bug for not
closing :)
Assignee: bugs → sfraser_bugs
Component: Preferences → Widget: Mac
Keywords: crash
Product: Firefox → Core
QA Contact: mconnor
Summary: View Cookies Dialog won't close. → View Cookies Dialog won't close. [@ HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)]
Version: unspecified → 1.7 Branch
Summary: View Cookies Dialog won't close. [@ HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)] → View Cookies Dialog crashes on close. [@ HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)]
(Reporter)

Comment 2

13 years ago
Here's another trackback ID: TB2706327E based on the same problem.  A different
window, but the same problem.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

12 years ago
Another reason we need the OS symbols on Talkback.
Assignee: sfraser_bugs → joshmoz
QA Contact: mac

Comment 5

12 years ago
OS bug triggered by the sheet-on-sheet arrangement in Firefox 1.0?

We don't use the same arrangement for the cookie pref UI any longer in 1.5. 
Regardless, I can't reproduce in 1.0.7 on 10.4.2.

Comment 6

10 years ago
WFM, Firefox 1.5.0.12, 2.0.0.4 and trunk on MacOSX 10.4.10

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
Crash Signature: [@ HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)]
You need to log in before you can comment on or make changes to this bug.