XUL Textbox Background-color Style doesnt work

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Russ Tyndall, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Setting the background color style on a xul:textbox either directly on the XUL
or via javascript, does not work
(Reporter)

Comment 1

13 years ago
Created attachment 169397 [details]
an example of the background-color  style not working
Assignee: dbaron → jag
Component: Style System (CSS) → XP Toolkit/Widgets
QA Contact: ian → jrgmorrison
(Reporter)

Comment 2

13 years ago
OK, Border styling also doesnt work.  Neither does using a class instead of
styles.  
I see red; that's what I'm supposed to see, right?  works for me with build
2004-12-22-04.  What build are you using, by the way?

Comment 4

13 years ago
desired: A textbox whose background color is red
actual: a plain vanilla textbox

Running Firefox 1.0 release...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/0.9.1+ StumbleUpon/1.995

Comment 5

13 years ago
Fresh install of firefox latest nightly with no extensions applied... still
doesn't work.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041222
Firefox/1.0+
Nathan; if you try the latest Seamonkey build (either [   ]
mozilla-win32-installer.exe or mozilla-win32-stub-installer.exe available from
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/), does this then
work for you?  If so, there's something odd about Firefox (but I doubt it).

The Firefox nightly you point to; is that trunk or Aviary branch?  A new build
(post 1.0) of Firefox should also work, I suspect.

Comment 7

13 years ago
Created attachment 170926 [details]
Same as above without spurious javascript

This is the same as the other attachment without trying to call non-existant
javascript in the onload function. Still shows the main bug though.

Comment 8

13 years ago
I'm still getting plane white. No red background. This is with the latest
seamonkey nightly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111

Comment 9

13 years ago
Also viewed with latest firefox trunk, doesn't work. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050110
Firefox/1.0+
I get a white box.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050109
--enable-application=suite --enable-svg --enable-svg-renderer-gdiplus
--enable-crypto --disable-tests --enable-debug --disable-optimize
--enable-extensions=all
You need to set -moz-appearance:none to be able to get non-system-appearance
styling for widgets.

Marking invalid, but please reopen if the problem is still ther with
-moz-appearance:none.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.