Feature Request: disable find-bar initiated scrolling of content window until after "findnext" button or "enter" is pressed

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
14 years ago
9 years ago

People

(Reporter: mmontag, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Some of the commentors in bug:250309 touched upon this in passing, but this
seems to be a separate issue to me.
Often I find myself reading a page and simultaneously typing in a text string
that I will want to find in that page.  With FAYT set up they way it is, the
moment it finds a text string that matches, the content window scrolls down
interupting my reading.  It would be very nice to have the option for the Find
Bar to not search the text until it is told to either by pressing the 'Find
Next' button or hitting 'Enter'.

Reproducible: Always
Find Next should find the second result, not the first, that's expected by all
Find implementations I've ever used.  Simply put, finding a string in a page and
reading the content are mutally exclusive, the simple "fix" for this is to not
start searching if you're reading...

Even as a pref this really doesn't make sense, and we're not going to support this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Duplicate of this bug: 515370
Duplicate of this bug: 533253

Comment 4

9 years ago
(In reply to comment #1)
Mike Connor, please do tell which part(s) of the following sentence you do not understand:

"I want to be taken elsewhere on the page ONLY if the word I'm looking for actually exists, OTHERWISE there's no use distracting me from what I'm reading right now".

Firefox is the ONLY BROWSER I tried that doesn't have a non-incremental search mode. Apparently, the reason is not that its developers are smarter than the others'.

Comment 5

9 years ago
My previous comment is also directed at Ria Klaassen, of course.
You need to log in before you can comment on or make changes to this bug.