Preference windows in firefox is not modal

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: rsubbu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
in firefox when edit->preference dialog is opened.
I can go back to parent window and control it by keyboard ( CTRL+Q, CTRL+w,
CTRL+L... etc)
I happening in thunderbird , sunbird also

I using linux suse 9.1.

Comment 1

14 years ago
In Novell Linux Desktop too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is by design. See the various User Interface Guidelines (Windows, Mac,
Gnome) for more information.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

14 years ago
Just what one more clarification in this...
Then only why keyboard is allowed, why not mouse event. I'm not able to click
the menus with mouse.
Severity: major → critical
(Reporter)

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Please do not reopen bugs, unless you have a *very good* reason, which you haven't.

I don't know why the keyboard/mouse behaviour is like it is, because I don't
know that code really well. File a bug about this and see what happens.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.