Unable to move more than one message from IMAP Sent to Local Folders

RESOLVED DUPLICATE of bug 259656

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 259656
14 years ago
12 years ago

People

(Reporter: david.dieterich, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Problem Description:  Unable to move more than one message at a time to Local
Folders.  Need to be able to pull all Sent messages from the server to a Local
Folder at once.  Other email clients offer this functionality.

Steps to Reproduce:
1. Select two or more messages in your email server account using Crtl or Ctrl A.
2. Drag them to a Local Folder.
>>> Nothing happens 
3. Select two or more messages  in your email server account.
4. File | Local Folders | <some_local_folder>
>>> Nothing happens 

Impact:  High.  With server quotas it is very valuable to be able to move all
your files off the server at once. I've got >400 Sent messages am I'm not
looking forward to moving then one by one. 

Workaround: This bug can be worked around partially by changing the Copies &
Folders Account Setting to place a copy on a local folder when sending, instead
of on the server. This doesn't solve the problem of course.

Updated

14 years ago
Assignee: bugs → mscott
Component: File Handling → Mail Window Front End
Product: Firefox → Thunderbird
QA Contact: bmo
Version: 1.0 Branch → unspecified
(Reporter)

Comment 1

14 years ago
Thunderbird version 1.0 (20041206).  Thanks to whoever changed the Product, I
was having trouble doing so due to a invalid Component error.
(Assignee)

Comment 2

14 years ago
this is a dup. But, I was never able to recreate the problem the original
reporter had. In other words, this works fine for me. Do you have your imap sent
folder configured for offline use? What kind of imap server are you using? Can
you attach or e-mail me an imap protocol log of a session where you attempt to
copy two messages from the imap sent folder to the local sent folder?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
A1.  I did not have my IMAP Sent folder configured for Offline Use.  I did this
and repeated the steps and they did not work.  However, I did click the Download
button and Thunderbird got very busy. My 780 messages seemed to get downloaded
somewhere, but they are still in my IMAP Sent folder and are not anywhere in
Local Folders (I did a search). I would expect to be asked where I wanted them
downloaded to, or to have them get downloaded to Local Folders | Sent. 
A2. I don't know what type of IMAP server I am using.  If there are settings I
can check, let me know.
A3. I'll attempt to attach or email you the log next.
(Assignee)

Comment 4

14 years ago
OK, I'd prefer that you didn't configure your sent folder for offline use - that
will make the log more informative.

Re the offline store, it goes in the imap server sub-directory of your user
profile directory, and it allows you to read messages while not connected to the
internet, by going into offline mode and reading the messages in your imap sent
mail folder, just like you would if you're online. It doesn't involve the local
folders directory.
(Reporter)

Comment 5

14 years ago
Email with log sent to Assignee.   Please note that I can select multiple
messages from my Inbox (or Trash!) and move them to a local folder no problem. 
It is just the Sent folder that exhibits this problem. Another (lousy)
workaround is to move everything in Sent to Inbox and then from Inbox to Local
Folders.
(Reporter)

Comment 6

14 years ago
Workaround: 
1. Empty Trash.
2. Move all Sent message to Trash.
>>> Don't panic, it may take a minute for them to show up
3. Move all messages from Trash to Local Folders | Sent
Severity: major → normal
Summary: Unable to move more than one message to Local Folders → Unable to move more than one message from IMAP Sent to Local Folders

Comment 7

14 years ago
whether it be (a) "copy to sent" (IMAP),  or (b) copy multiple messages from any
folder TO the sent folder (IMAP) -- something is VERY broken with Tbird v1.0+
and sent folder access/contents/mgmt/etc.

For the first time in 6+ years of using communicator, Mozilla, Tbird -- I'm
actually downloading Eudora/Mulberry for use until this is fixed.    

It would seem Moz Develop has lapsed into M$ strategy:  prioritize "wiz-bang
features" over core stability and reliability.   Case in point:  "spell while
you type" .... ZZZzzz... wake me when it's over.  

(Assignee)

Comment 8

14 years ago
I've spent many hours on this and not even been able to reproduce it. I've made
special builds to try to track this down to no avail.  So don't confuse lack of
progress with lack of effort...

Comment 9

14 years ago
Hello -- 

NOTE -- the specific problem I've observed in copying multiple messages TO sent
folder (in one operation).

As a work-around to current problem with "copy to sent", I've been BCC myself --
and after see good number of BCC'ed msgs in Inbox, I select (via Control-click)
and drag all to SENT folder (after first insuring access to sent possible --
click on sent folder, insure it loads).  

When I do as detailed above, the messages do NOT copy to Sent folder.  Actually,
the msgs disappear completely (bad) -- the only way to recover is select
operation "//Edit menu/Undo ...".

Using Tbird 1.0 and IMAP over SSL to Sun Messagaing JES/Q42004.   This
essentially IDLE server used by approx 10 people on dedicated T-1. 



Comment 10

14 years ago
hello -- checking this with Tbird 0.9 release and haven't observed problem (as
of yet).   

Note -- this "copy multiple msgs to/from Sent" and bug #224795 seemed to co-incide.

I'll continue checking both.
(Assignee)

Comment 11

14 years ago
garrett, have you tried generating an imap protocol log that shows the problem?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

(Assignee)

Comment 12

14 years ago
Created attachment 173317 [details] [diff] [review]
add more protocol logging for error cases

this adds some more protocol logging of error cases that might explain the log
that David sent me. I also moved the clearing of a weak ref pointer to the ui
thread to fix those assertions.
Attachment #173317 - Flags: superreview?(mscott)

Comment 13

14 years ago
Hello David -- thanks for the URL (my apologies for being unaware).

I will execute shortly with Tbird 1.0 -- I assume this is version I should be
testing??  Also, even thought the log info was specifically written for Mozilla,
I'm assuming similar approach will apply to Thunderbird (and Firefox).

Thanks in adv.  -GA

Updated

14 years ago
Attachment #173317 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 14

14 years ago
David and Garratt, can you try tomorrow's nightly trunk thunderbird build? It
has more logging for the case of failure to copy multiple imap messages to a
local folder.

Comment 15

14 years ago
Hello David -- please check bug #224795 comment #29.  Thanks -GA
(Reporter)

Comment 16

14 years ago
Fixed in trunk build version 0.6+ (20050210).  
GA, you want to verify that it's fixed there for you too?
(Assignee)

Comment 17

13 years ago
fix should be in tomorrow's trunk build

*** This bug has been marked as a duplicate of 259656 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 18

12 years ago
Comment on attachment 173317 [details] [diff] [review]
add more protocol logging for error cases

>Index: nsImapProtocol.cpp
>===================================================================
>RCS file: /cvsroot/mozilla/mailnews/imap/src/nsImapProtocol.cpp,v
>retrieving revision 1.590
>diff -u -w -r1.590 nsImapProtocol.cpp
>--- nsImapProtocol.cpp	3 Feb 2005 15:22:14 -0000	1.590
>+++ nsImapProtocol.cpp	3 Feb 2005 23:03:02 -0000
>@@ -946,7 +946,6 @@
>   me->m_runningUrl = nsnull;
>   CloseStreams();
>   me->m_sinkEventQueue = nsnull;
>-  me->m_server = nsnull;
>   me->m_imapMailFolderSink = nsnull;
>   me->m_imapMessageSink = nsnull;
>   m_iThread = nsnull;
>@@ -979,6 +978,7 @@
>   }
>   m_channelInputStream = nsnull;
>   m_channelOutputStream = nsnull;
>+  m_server = nsnull;
> }
> 
> 
Was this change intentional? You're now clearing m_server on the wrong thread. (I don't know if you were before.)
(Assignee)

Comment 19

12 years ago
the intent was to clear it on the UI thread to fix some assertions - but TellThreadToDie gets called from both the UI thread and the imap thread, in some situations...
You need to log in before you can comment on or make changes to this bug.