Plugins shows Real Player as Windows Media Player

RESOLVED FIXED in 1.1

Status

RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: alex, Assigned: Bugzilla-alanjstrBugs)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
First of all I wanted to thank all those who worked on the new UMO - great job,
thanks! :)

I have a few comments, a typo report etc:
1. Firefox > Plugins - the description of "Windows Media Player" says something
about RealPlayer, I believe it's a typo.

2. The name of the submitter of a comment/rating/review is displayed using the
same style/font/color as the title of the comment. This is a bit confusing IMHO.
For example: Dave submits a comment and says "Great extension". His comment will
say "Great extension by Dave" :) ,  etc.

3. Developer panel - submitting a new extension version for approval, asks for a
description of the new extension version. The description appears immediately,
before the version is approved. This can be confusing to the users - they see a
new description along with the old version. An easy workaround would be for me
to wait and update the description -after- the version is approved, but it would
be nice if every version had its own description.

That's it for now, thanks again, I'm really enjoying the new system :)

Alex
(Assignee)

Comment 1

14 years ago
There is a recent changes section that only accompanies the version.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> There is a recent changes section that only accompanies the version.

Yes, but sometimes there are major changes/additions and the description needs
to change. And these major changes will be missing in the version that the user
downloads :). This is no biggy, though, I guess a developer can wait until the
extension is approved and only then update the description. Maybe add a small
warning in the entry form to warn the developer that this is the behavior?
(Reporter)

Comment 3

14 years ago
A funny follow up on the comment author having the same font as the comment title:
Farkit comment:
--------------------------
Best. Extention. Ever. (Except for the better ones by Brandon Sharitt
    "Thank's to Farkit I can now waste time more efficiently and get more women
now."
--------------------------
It looks like Brandon claims he has created better extensions than Farkit :D

One more issue - the "Auto-detect" browser feature seems to be a bit problematic
- with FF 1.0 I have to manually switch to "Firefox 1.0" in order to see the 1.0
extensions. 

Updated

14 years ago
Assignee: psychoticwolf → nobody
(Assignee)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

14 years ago
*** Bug 276131 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

14 years ago
*** Bug 278037 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

14 years ago
Created attachment 171420 [details] [diff] [review]
Replace RealPlayer with WMP
Assignee: nobody → Bugzilla-alanjstrBugs
Status: NEW → ASSIGNED
Attachment #171420 - Flags: first-review?(cst)
(Assignee)

Comment 7

14 years ago
(In reply to comment #0)
> 1. Firefox > Plugins - the description of "Windows Media Player" says something
> about RealPlayer, I believe it's a typo.

Patch attached.  Soon to be checked into cvs.

> 2. The name of the submitter of a comment/rating/review is displayed using the
> same style/font/color as the title of the comment. 

Please file a separate bug

> 3. Developer panel - submitting a new extension version for approval, asks for a
> description of the new extension version. The description appears immediately,
> before the version is approved. 

Please file a separate bug.  This will probably be resolved by a note on the dev
panel that warns the user.
Attachment #171420 - Flags: first-review?(cst) → first-review+
Trunk:
Checking in mozilla/webtools/update/plugins/index.php;
/cvsroot/mozilla/webtools/update/plugins/index.php,v  <--  index.php
new revision: 1.4; previous revision: 1.3
done

Branch:
Checking in mozilla/webtools/update/plugins/index.php;
/cvsroot/mozilla/webtools/update/plugins/index.php,v  <--  index.php
new revision: 1.3.2.1; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

14 years ago
*** Bug 279963 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: New UMO - some minor issues → Plugins shows Real Player as Windows Media Player
Target Milestone: 1.0 → 1.1
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.