No priority is higher priority than P1

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Ed Grimm, Assigned: myk)

Tracking

Details

(Reporter)

Description

14 years ago
When someone enters a bug without specifying a priority, it's considered more
important than any bug which has been graced with a priority.

A better implementation would count a null priorty as 1.5, 2.5, 3.5, or 4.5,
depending upon configuration.  After all, no bug is more important than a P1, by
definition; as yet unrated bugs should therefore not be listed assuming such
priority.  Depending upon the proportion of bugs under P1, the rate of P2-Pn bug
closings, and the cost of not correctly prioritizing an unrated bug that should
be P1, each group should be able to determine for themselves how these compare
in priority with P2, P3, and P4.  As no bug is less important than a P5, unrated
bugs should appear before them (after all, on average, an unrated bug will beat
out a P5.)

Note that, post bug 270381, the effective importance/priority of an unrated bug
should be able to be set with full floating-point precision, for those who
really care.  Not that I'd mind if it was still restricted to the four values I
mentioned, as in this case, I don't care that much.  But it is a detail that
could influence the initial design, so I thought I'd mention it.

As setting a default priority is a potential workaround for this bug, I'm
considering it normal severity; otherwise it would be major.
my thinking is this is the correct behavour.  a bug that hasn't had the priority
set needs attention first, so the priority can be set correctly.
(Reporter)

Comment 2

14 years ago
In response to comment 1,
I think you're misunderstanding what is meant by top priority, at least in the
business world.

However, for an example of how the current setting can go wrong - do a search
for all open bugs in product firefox, sorted by importance.  Then tell me again
how that is the correct order.

Updated

13 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 3

13 years ago
When entering a new bug, the priority is set to the 'defaultpriority' parameter defined in editparams.cgi. Since Bugzilla 2.20, you can choose a sortkey for priorities, allowing you to sort them as you want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.