Closed Bug 275957 Opened 15 years ago Closed 11 years ago

"I'm feeling lucky" keyword search should inform user the first time it is used

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: raceronline, Unassigned)

References

Details

(Keywords: helpwanted)

Attachments

(1 file)

When a user enters something which triggers the "I'm feeling lucky" keyword
search (from the location bar), FireFox should pop up a window that informs the
user what they have done. In addition, it would provide the option on that
window to disable the feature. This popup would only be shown the first time
that this event is triggered.

Currently, the keyword search is quite confusing to new users who do not
understand it. If a user does not know about the feature, and accidentally
enters an invalid URL, then it can take them to a site completely unrelated to
the one that they intended to go to, with no warning. This popup would inform
the user that they have started a search. It would then give them the option to
 continue, cancel, or completely disable the auto-search feature. There should
also be a checkbox (checked by default) that would say to not show this message
again.
Below is a rough example of what the popup would look like. Note that the xxxx
would be replaced by the text being searched for.

-- Keyword Search --
You have started a keyword search for "xxxx". This will try to find the web site
that most closely matches your text and then take you to that site.
Continue?
[ Yes ] [ No ] [ Disable ] ... [x] Do not show this message again
Interesting idea. I'm going to confirm this RFE as worthy of further 
consideration. Konqueror actually does something similar when one misses a link 
when middle mouse clicking if the contents of the X buffer don't look like a 
url before sending it off to Google for a regular Google search. 
 
I would suggest a change to the wording to make it clear this is a Google "I'm 
Feeling Lucky" search though, something more like: 
 
 
A Google I'm Feeling Lucky search has been initiated for "xxxx" and you will be 
taken to the best matching site if you choose to continue. 
Continue? 
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 289029 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.1?
At the least, this will not be a popup.  Infobar, maybe, but the wording has to
be more generic since keyword.URL can change.
A lot of people don't understand what's happening here, and this was a known
issue for 1.0 that we should try and figure out for 1.1.

The most common complaint comes from a site's owner.  When they type in foo
versus foo.com they expect to go to foo.com.  However, typing in foo takes them
to another site that happens to have a higher google ranking in this case.



I would love to have an infobar for this, but we shouldn't block the release on it.
Assignee: bugs → mconnor
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Keywords: helpwanted
*** Bug 290080 has been marked as a duplicate of this bug. ***
I think some indication that the "I'm Feeling Lucky" search was done needs to be
visible every time it happens. It's too easy to make a typo...

Also, see bug 302974.
A possible fix might be not to do "I'm feeling lucky" searches by default.
A simple google search might be enough, and then the user would have the choice
of which website to go to. He will also know that the URL he typed in does not
exist.

A user might disable the automatic "I'm feeling lucky" feature by doing this:
1. type "about:config" in the location bar
2. change the value of "keyword.URL" from:
"http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="
to:
"http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="

I've included a patch that does this in the source package, I would appreciate
if anyone would be interested in applying it.
I forgot to mention:
A popup indicating that a search is done, and requesting user approval of the
search is the most appropiate way to handle this IMHO.
My "patch" is just a temporary way to avoid automatic search redirections.
(In reply to comment #9)
> A possible fix might be not to do "I'm feeling lucky" searches by default.
> A simple google search might be enough, and then the user would have the choice
> of which website to go to. He will also know that the URL he typed in does not
> exist.
> 
> A user might disable the automatic "I'm feeling lucky" feature by doing this:
> 1. type "about:config" in the location bar
> 2. change the value of "keyword.URL" from:
> "http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="
> to:
> "http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q="
> 
> I've included a patch that does this in the source package, I would appreciate
> if anyone would be interested in applying it.
> 

(In reply to comment #9)
> A possible fix might be not to do "I'm feeling lucky" searches by default.

That is not the purpose of this bug, there is a different bug for that (which
was marked Wontfix). Please add comments about changing the default behaviour to
that bug.

(p.s. please don't quote text unecessarily when replying in bugzilla as it makes
bugs harder to follow)
Mass edit: Changing QA to default QA Contact
QA Contact: davidpjames → password.manager
Mass edit: Setting correct QA for location bar/autocomplete. My bad. I forgot I had once been Autocomplete QA too. Hmm, why can't I just set the QA of bugs to the default QA of the component in a mass edit rather than having to do it manually...?
QA Contact: password.manager → location.bar
Please refer bug 347703 for a related non-URL search visibility usability enhancement proposal.
Hardware: PC → All
I think the user should be alerted by a pop-up message the first time they use this feature.  That message could say something along the lines of "You have entered some text into the Location bar that is not a valid web address. Firefox can try to find the most relevant pages to your request using Google.  You can disable this feature in Options."  Then below that would be just a "OK" button and a automatically checked "Do not show this message again" checkbox.  I don't think there's a need to put Yes, No, and Disable buttons on the message, but the message should rather just tell the user to go to the Options menu to disable the feature for the future.  Speaking of that, there needs to be a option in the Options menu to disable the feature.

Also, so the user knows everytime he/her invokes this feature, there should be a little graphic (magnifying glass, four leaf clover, etc.) next to the user's cursor displayed every time this feature is invoked.
I think the need for this is drastically reduced by using Browse by Name, since you only end up redirected if its an obvious match, i.e. "hertz" takes you to hertz.com.
Assignee: mconnor → nobody
going to wontfix this, we now take the obvious, high percentage match, or search, and it's very much not confusing.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Mike, think you meant WONTFIX, based on comment 18.
Resolution: FIXED → WONTFIX
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.