move style to stylesheet from inline.

RESOLVED WONTFIX

Status

--
trivial
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: spam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: 

show some examples:
www.mozilla.org/
<br style="clear: both;">
<h2 style="margin-top: 0;">
<ul class="news" style="margin-left: 10px;">
<a href="products/camino/" style="text-decoration: none;">
<img src="images/camino16.png" height="16" width="16" alt="Camino icon"
style="vertical-align: middle;">
<span style="text-decoration: underline;">Camino 0.8.2</span>

/products/firefox/all.html
 <style type="text/css">
snip stylesheet here.
...

Reproducible: Always

Steps to Reproduce:

Actual Results:  



Expected Results:  
move them to stylesheet file
add some example
/products/firefox/ uses(show above are excluded)
<p style="margin-bottom: 0">
<div style="margin: 6px 0 0 4px;">

/products/thunderbird/ uses
<h3 style="margin-top: 0;">
If the styles really are specific to the page, they should be there (in a style
element in the head or in style attributes), since moving them to the site
stylesheet just makes the site stylesheet much harder to maintain.
add example
/support/ uses 
<img src="http://www.mozilla.org/products/firefox/guidebook.jpg" width="160"
height="180" alt="Firefox Guidebook" style="float: left; border: none;">

if inline stylesheet is necessary anyway, you should include this line to html
header:
<meta http-equiv="Content-Style-Type" content="text/css">
see http://www.w3.org/TR/html401/present/styles.html#h-14.2.1

Comment 4

14 years ago
(In reply to comment #2)
> If the styles really are specific to the page, they should be there (in a style
> element in the head or in style attributes), since moving them to the site
> stylesheet just makes the site stylesheet much harder to maintain.

The homepage has its own CSS file. <http://www.mozilla.org/css/cavendish/home.css>
Status: UNCONFIRMED → NEW
Ever confirmed: true
I know about Content-Style-Type (see bug 216100 comment 0, bug 84564, bug
161268), but it's really rather silly -- text/css should just officially be the
default.  That said, we could add it to the wrapper.
Assignee: www-mozilla-org → nobody
QA Contact: danielwang → www-mozilla-org
(Assignee)

Updated

10 years ago
Product: mozilla.org → Websites

Comment 6

9 years ago
Closing as wontfix.  Although this bug is referring to an older site design, the new site design does have some inline page specific styling.  If there is a good reason for us to rethink this practice, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.