Closed Bug 276014 Opened 18 years ago Closed 18 years ago

Firefox chooses Outlook over the default e-mail application

Categories

(Firefox :: General, defect)

1.0 Branch
x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 202497

People

(Reporter: moreno, Assigned: bugzilla)

Details

Maybe this does not fall under the "dictionary definition" of a bug; 
but it defies any logic I can think of, so I consider it a bug. 

On my machine, I have Mozilla 1.7 to handle e-mail (i.e., it is the 
default mail application).  I also installed Thunderbird, to evaluate 
it -- I have not made it the default mail application yet. 

Given the above, when I want to e-mail a link to a page I'm presently 
viewing with Firefox (menu File/Send Link...), it opens MS Outlook 
Express!!! 

Isn't Firefox supposed to be a close relative to Thunderdbird??? 
I would think that it would attempt to open Thunderbird if it finds 
it, right?  Wrong, of course! -- maybe Thunderbird is not properly 
configured;  after all, if it's not the default application perhaps 
it's a bad idea to attempt to use it...  But HELLO?  Outlook IS NOT 
my default mail application either; I've NEVER used it and thus it's 
not configured to send or receive e-mail. 

It's not a matter of getting emotional over advocacy issues and 
Microsoftphobias -- I simply can not think of an excuse for using 
anything other than the application configured as the default mail 
application when I use the menu "File/Send Link..." to send the 
currently displayed page on Firefox. 

I look forward to see this "bug" fixed,

Carlos
--
The problem is that Mozilla 1.7 doesn't register itself as the default handler
for mailto: links, so Outlook is called.

*** This bug has been marked as a duplicate of 202497 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.