When "mailbox unavailable" it doesn't report what mail address is unavailable

RESOLVED DUPLICATE of bug 374388

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 374388
13 years ago
11 years ago

People

(Reporter: David, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When I send an e-mail to multiple recipients, my pop server answer "Requested
mail action not taken: mailbox unavailable". That is because one e-mail address
doesn't really exist and no mail is sent.

The problem is that thunderbird doesn't report what e-mail address is causing
the probles so I could remove it and send the message to the rest. However,
Outlook  express reports what e-mail address is causing the problem.

This is a handicap for who send messages with multiple recipients.
I use thunderbird 1.0.
Thanks.

David

Comment 1

13 years ago
Agreed, there should be some more info (log?) about message send failure...
Running version 1.0 (Czech localization)
Petr

Comment 2

11 years ago
Thunderbird doesn't send messages to individual recipient, the SMTP server does that; all TB can do is report the error returned by the server.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 3

11 years ago
Mike, can you define "SMTP server" in the context what you just wrote?  Are you talking about some code/component in TB that people call the "SMTP server" or are you talking about a remote MTA?  (I am a e-mail sysadmin, and have never looked at TB code.)

The issue that I think that David opened this ticket and why I added myself as an interested party is that when TB sends e-mail to a MSA (Message Submission Agent) or MTA (Message Transport Agent) that is also authoritive for the domain the e-mail is being sent to TB does not report back to the user what address was bad or had problems.

i.e. take the following message submission (TB is the client (C) and the server (S) is the remote MSA): 


S->C 220 smtp.example.com
C->S EHLO thunderbird.emailclient.example.com
S->C 250-smtp.example.com
S->C 250-8BITMIME
S->C 250-PIPELINING
S->C 250-DSN
S->C 250-ENHANCEDSTATUSCODES
S->C 250-HELP
S->C 250-XLOOP F4298690CF3301E77C662FAC9CC210EC

SASL information is sent/received

S->C 250-AUTH PLAIN LOGIN
S->C 250-AUTH=LOGIN
S->C 250 SIZE 0
C->S AUTH PLAIN AHNjb3R0BJB2LjB2cw==
S->C 235 PLAIN authentication successful.
C->S MAIL FROM:<sender@example.com> SIZE=1836
S->C 250 2.5.0 Address and options OK.
C->S RCPT TO:<goodaddress-1@example.com>
S->C 250 2.1.5 goodaddress-1@example.com OK.
C->S RCPT TO:<goodaddress-2@example.com>
S->C 250 2.1.5 goodaddress-2@example.com OK.
C->S RCPT TO:<badaddress@example.com>"
S->C 452 4.2.1 mailbox temporarily disabled: badaddress@example.com"

TB then ends the server connection ungracefully (no QUIT...just drops the socket...bad. :( and reports to the user a very generic error message.  IMO, TB should report the status of "badaddress@example.com", and handled the other recipients accordingly.

I have not tested TB recently on this issue, so the behaviour might have changed in 1.5, but until in can be shown that TB 1.5+ handles and notifies the sender of a 4xx or 5xx response code to a RCPT TO command with some meaningful information, I would request that this ticket be reopened.

Thanks.

Comment 4

11 years ago
I don't know if TB 2.0 addresses this issue, but I believe it now at least drops the connection a little more gracefully, with a QUIT.

Comment 5

11 years ago
I believe Thunderbird does actually issue individual RCPT TO commands. Re-opening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

11 years ago
To whomever is in charge....IMO, this bug is very similar to 197134 if not the same. :)

Comment 7

11 years ago
As I read this and bug 197134, I also see a connection to bug 300937 in that the Networking:SMTP component needs to be able to handle the different SMTP response codes a submission server might give back to TB gracefully.

Comment 8

11 years ago
The patch I'm working on for bug 361433 (draft already attached to that bug) also adds a better feedback which address(es) failed.
It's a minimal solution since it doesn't report a summary as has been proposed in bug 197134 comment 3 but an alert for each address failing.

Comment 9

11 years ago
Addressed in bug 374388, so duping.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374388
You need to log in before you can comment on or make changes to this bug.