fieldset/legend's position wrongly computed when dynamically inserted

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: aquarichy, Assigned: mats)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041116 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0-2ubuntu3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041116 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0-2ubuntu3)

Using Glazman et al's HTMLoverlays as an example, fieldsets with their legends
are erroneously rendered when they are dynamically inserted.  Fieldsets without
legends appear normally.  


http://aquarichy.nimnastian.net/test/index-proper.html
Above is a quick test of how the legend should appear.  The HTML is very simple
and short, of course.

Below is a page that should render identically, but does not.  The legend is
computed as being within the fieldset rather than riding its border.  
http://aquarichy.nimnastian.net/test/index.html

I wrote Daniel Glazman who suggested it may be a Mozilla dom+layout bug where
the element's position is poorly computed by Mozilla when dynamically inserted
from the overlay into the document tree.

More on HTMLoverlays can be found here: 
http://disruptive-innovations.com/zoo/20040830/HTMLoverlays.html

Reproducible: Always

Steps to Reproduce:
1. create a page where a fieldset with a legend is kept in an overlay.xml
2. use htmloverlays with overlay.xml
3. the legend is improperly rendered

Actual Results:  
I had created the page without overlays, wherein it appeared properly.

Expected Results:  
When overlays were applied, it should look identical (in this case) to when
overlays were not used.  That is, the content between the legend tags should
have rode the fieldset's border, rather than fall within it.

Comment 1

14 years ago
Could you please create a reduced selfcontained testcase without all that
overlay voodoo? It looks like a real layout bug, but its hard to tell what goes
wrong.
(Reporter)

Comment 2

14 years ago
I think the problem is a duplicate of 
<a href="show_bug.cgi?id=233664">233664</a>
where inserting elements via javascript result in "frame construction issues" as
"legend frames are just all broken".

After spending five hours trying to learn DOM and JavaScript, I gave up and
looked if there were any other, more specific bugs that described this behaviour :)

Updated

14 years ago
Depends on: 233664
(Assignee)

Updated

14 years ago
No longer depends on: 233664
(Assignee)

Comment 3

14 years ago
URL works for me in a local build with fixes for bug 276104 and bug 236071.
Assignee: general → mats.palmgren
Status: UNCONFIRMED → NEW
Depends on: 236071, 276104
Ever confirmed: true
(Assignee)

Comment 4

14 years ago
URL is 404, but I'm trusting my last comment and I say this is fixed now.
Please reopen if not and provide new testcase.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.