If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The Mac OS X 10.0 selection on the Guided Bug entry OS dropdown comes back as an illegal OS

RESOLVED DUPLICATE of bug 275064

Status

()

bugzilla.mozilla.org
General
--
minor
RESOLVED DUPLICATE of bug 275064
13 years ago
6 years ago

People

(Reporter: Bob Adolf, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I was using the guided bug entry to add a bug, and by default Mac OS X 10.0 was
selected. Assuming that the system had correctly auto-detected my OS, I added
the bug and hit submit. I got a page that said "A legal OS/Version was not set".
(It also told me to send it by email to bugzilla-admin@mozilla, but I am under
the impression that you do not take bugs by email).

To solve this, I hit the back button and selected MacOS X instead of Mac OS X
10.0. This solved the problem, but it should be fixed. Also, I find it
interesting that the non-guided bug submission form does not have this problem.
I could not find it as a previous bug, but it seems at some point it must have
been addressed.

It seems that the solution to this is just to remove the Mac OS X 10.0 option.
It is incorrect anyways. I am using 10.3, not 10.0. The auto-detect should
select MacOS X as the default.

Reproducible: Always

Steps to Reproduce:
Just make sure it's the GUIDED bug entry, not the normal one. Only the guided
bug entry has the bug.
Actual Results:  
I got this page: (text copied from the page itself)

Bugzilla  Version 2.19.1+ 

Internal Error

Bugzilla has suffered an internal error. Please save this page and send  it to
bugzilla-admin@mozilla.org with details of what you were doing at  the time this
message appeared.

URL: file:/Users/rdadolf/Desktop/post_bug.cgi.html

URL: https://bugzilla.mozilla.org/post_bug.cgi

 A legal OS/Version was not set.

*** This bug has been marked as a duplicate of 275064 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.