If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

background image inside CSS block extends past rounded corners

VERIFIED DUPLICATE of bug 24998

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 24998
13 years ago
13 years ago

People

(Reporter: Dan Hirsch, Unassigned)

Tracking

({css-moz, helpwanted, testcase})

1.7 Branch
x86
Windows XP
css-moz, helpwanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

1.03 KB, text/html
Details
(Reporter)

Description

13 years ago
If you combine any -moz-border-radius-<whatever> style with a css bacground
image, the background image will exend past the rounded corners of the border.
This does not also occur with background colors. It works fine if the background
image is specified for the containing block (see the attatched screenshot).
(Reporter)

Comment 1

13 years ago
Created attachment 169620 [details]
A screenshot
(Reporter)

Comment 2

13 years ago
Created attachment 169621 [details]
This is the source from the screenshot

Unzip it anywhere and open "test.html". Note: it unzips to the current
directory.

Comment 3

13 years ago
keyword should be css-moz
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

13 years ago
Keywords: css-moz

Comment 4

13 years ago
Created attachment 169935 [details]
testcase
Attachment #169620 - Attachment is obsolete: true
Attachment #169621 - Attachment is obsolete: true

Updated

13 years ago
Keywords: helpwanted, testcase
QA Contact: core.layout → ian

*** This bug has been marked as a duplicate of 24998 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Ray, please search for dups before confirming, ok?

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.