First page printed with a large blank space

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If the page of the URL:
http://java.sun.com/docs/books/tutorial/java/concepts/class.html
is printed (or in print preview), the first page is almost empty: nothing after
the "What Is a Class?" title.  Everything starts only on the second page!  Strange.

But if you go to the other pages and try a print (preview), everything is OK.

I've taken a look at the source, and all I could see is that there's a
<backquote> tag.  But this tag also exists in other pages.  Why only in this
page does this happen??


Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
Over to Printing.
Assignee: firefox → core.printing
Component: General → Printing
Product: Firefox → Core
QA Contact: firefox.general
Version: unspecified → Trunk

Updated

14 years ago
Summary: First page rendered strangely with a large blank space → First page printed with a large blank space

Comment 2

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041225

tested preview only, didn´t actually print.
Got three pages, third one only holding the documents footer.
Reducing size to 97% was showing 2 pages, 58% put it all on one page.
<blockquote></blockquote> is nested, and there is one surplus </blockquote> 

Printer settings: Canon Bubblejet BJ-330, paper size A4, tractor feed.
(Reporter)

Comment 3

14 years ago
Created attachment 169719 [details]
Print preview of page 1 = mostly blank

I'm not sure if my description of the problem was clear enough.  So I attach
two images.

The 1st one shows that after the title "What is a class?", there's nothing up
to the end of the page.

The 2nd one shows that the passage after that title starts indeed in page 2
instead of in page 1.
(Reporter)

Comment 4

14 years ago
Created attachment 169720 [details]
Print preview of page 2 = real beginning
Worksforme with a current trunk build...

Comment 6

13 years ago
WFM print and print preview on XP and w2k Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+

reporter, please reopen if you can recreate this on the newest version of FF.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.