If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Site tabs should have a current state

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Tabs on mozilla.org have a hover state to show which tab is currently
highlighted but have no current state to show which one is selected.  The
exception is the 'Store' tab which changes white when you select it. 
Screenshots are included at http://forums.mozillazine.org/viewtopic.php?t=190924

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
The CSS for this is allready there, but the difficulty is that there is no easy
way for the site build scripts to know what section of the site each page is
part of.

The store was easy, because it is actually a different set of files on a
separate server, all of which (obviously) are part of the "store" tab.

To turn "on" a tab, there is a body class setup for each tab (ex. <body
class="sectionStore">).

Comment 2

13 years ago
No place to vote here?
This is pretty much fixed now. I'll leave it open since there are a few sections
that don't work yet (Developers, and the Firefox and Thunderbird Help sections).
Also, I suspect, anything in NOMENU.

I've been thinking we need a better way of doing this stuff (NOWRAP, NOMENU). 
Comments at the top of the file would probably work, and could also be extended
to give a breadcrumb title and a breadcrumb parent page (from which the
proceeding titles would come).  We could even pick the appropriate section out
of the breadcrumb parent chain.

Comment 5

13 years ago
Another option is to have a sitemap.xml file that defines the structure of
mozilla.org. (As is done for developer.mozilla.org.)

Comment 6

13 years ago
If we're going that far we should just switch to DevMo's build system. But
Steven has fixed this for most high-profile pages through the templates.
Assignee: www-mozilla-org → nobody
QA Contact: danielwang → www-mozilla-org
(Assignee)

Updated

9 years ago
Product: mozilla.org → Websites

Comment 7

8 years ago
Resolving as fixed.  Although this was opened to refer to an older site design, the new site design does highlight the section link for pages within that section.  Note that there's a lot of content on the site that's not part of one of the top-level sections, so not all pages have highlighting in the main nav.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.