Problems with painting the page and scroll bar

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Charles Mak, Assigned: harishd)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MAKINGTEST] andyb@rconnect.com, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Overview: Problems with painting the page and scroll bar

Steps to Reproduce: goto url

Actual Results: Sometimes, nothing but a grey page appears. Sometimes, 
only beginning of the page is shown. When part of the page is painted, the 
scroll bars are shown without the images. Same thing happens to the scroll 
bars when you try to view the source code.

Expected Results: the entire page should be drawn and the scroll bars should 
appear correctly.

Build: 2000-0212-16 on Windows NT (sp)

Comment 1

19 years ago
Page caused a crash on linux build 2000-2-15-10 ! copy url
http://www.ci.shrewsbury.ma.us/email/a-m.htm , a little bit draws, try to
scroll, and crash:
Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 19241 error_code 11 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 19243 error_code 9 request_code 55 minor_code 0

Comment 2

19 years ago
No crash in the 2000-02-17-15 Win98 build, but I see the bug. It goes away if 
you get rid of the anchor part of the URL (the #a). Networking bug? I think this 
might be a URL problem.

I used view source on the page with the anchor, and the page only loads to the 
end of the <body> tag. Let me see if I can make a testcase.

Someone with permissions I don't have yet might change the OS to all and the 
component to Networking (to get it out of Browser-General).

Comment 3

19 years ago
Changing OS to "All" and component to "Networking." I will work on a testcase.
Component: Browser-General → Networking
OS: Windows NT → All
Whiteboard: [MAKINGTEST] andyb@rconnect.com

Comment 4

19 years ago
This page looks fine on 2000-03-08-13 Win32 build.  Please get latest build at: 
http://www.mozilla.org/binaries.html
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

19 years ago
Marking Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Created attachment 6463 [details]
screenshot of the problem
(Reporter)

Comment 7

19 years ago
this page does not look fine on build 2000-0312-08 WinNT (sp6). i'm seeing the 
same problems i saw before. please see screenshot above. 
(Reporter)

Comment 8

19 years ago
i'm still seeing the problems on Win32 2000-0316-08, so I'm reopening this bug.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Charles Mak:  Do you still see this bug?  (In what build?  Did you double-check
that "Use viewmanager2" is enabled in advanced prefs?)

Comment 10

18 years ago
petersen, can you reproduce with latest daily builds on any platform?
Assignee: leger → clayton
Status: REOPENED → NEW
Component: Networking → Layout
QA Contact: cbegle → petersen
(Assignee)

Comment 11

18 years ago
I'm not even able to load the above URL 
(http://www.ci.shrewsbury.ma.us/email/a-m.htm#a ).  However, if I first load 
http://www.ci.shrewsbury.ma.us/email/a-m.htm and then click on "A" ( the link 
)..then everything works fine! Could be networking? Giving bug to gagan.
Assignee: clayton → gagan

Comment 12

18 years ago
Wait a minute the original problem seems to be related to painting problems with 
this case. I do believe I already have a bug (as dup) that deals with the 
problem of loading a URL with a # in it. I don't want to hastily mark this one 
as dup. Harish if the original page loads fine for you (in terms of painting) 
then this should be marked as WORKSFORME. back to you to confirm the same. 
Assignee: gagan → harishd
Target Milestone: --- → M18
(Assignee)

Comment 13

18 years ago
I's unable to reach the above URL ( due to the presence of of # ). I assumed 
that was the condition stated ("Sometimes, nothing but a grey page appears") by 
Charles.  However, the good news is...I'm not seeing the problem anymore ( June 
6th build ).

Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.