Localization of RSS Account creates an inaccurate profile directory.

RESOLVED DUPLICATE of bug 313525

Status

MailNews Core
Feed Reader
--
major
RESOLVED DUPLICATE of bug 313525
14 years ago
9 years ago

People

(Reporter: Hiro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gone with bug 313525?])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
When the following files are localized and RSS account is created, a profile
directory is created by the unjust name.

   thunderbird/defaults/isp/rss.rdf

The directory of RSS account is created by the name unjust as follows.

   C:\Documents and Settings\NT Account Name\Application
Data\Thunderbird\Profiles\xxxxx.default\Mail/ヒ襞ケhヨ擎

Localization of rss.rdf is Japanese and it is created by UTF-8.

Reproducible: Always


Thunderbird 1.0 Release
Windows XP Pro SP1 & NTFS
(Reporter)

Comment 1

14 years ago
Created attachment 169689 [details]
rss.rdf localized in Japanese

The Thunderbird1.0 Japanese package by which this file is officially released
from Mozilla Japan is used similarly.
(Reporter)

Comment 2

14 years ago
additional comment:
In Mac OS X, when this rss.rdf is localized in Japanese, subscription of RSS
becomes impossible.

Comment 3

14 years ago
Created attachment 169732 [details]
panacea.dat with garbled folder RSS account

When I make RSS account with localized rss.rdf, "panacea.dat" in profile
directory
will be this.

Comment 4

14 years ago
Comment on attachment 169732 [details]
panacea.dat with garbled folder RSS account

// <!-- <mdb:mork:z v="1.4"/> -->
< <(a=c)> // (f=iso-8859-1)
  (8A=charset)(8B=folderName)(80=ns:msg:db:row:scope:folders:all)
  (81=ns:msg:db:table:kind:folders)(82=key)(83=flags)(84=totalMsgs)
  (85=totalUnreadMsgs)(86=pendingUnreadMsgs)(87=pendingMsgs)
  (88=expungedBytes)(89=folderSize)>

<(80
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\Local Folders\\Drafts.msf)(81=404)(82=0)
  (83=)(84=$E4$B8$8B$E6$9B$B8$E3$81$8D)(85
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\Local Folders\\Sent.msf)(86=204)(87
    =$E9$80$81$E4$BF$A1$E6$B8$88$E3$81$BF$E3$83$88$E3$83$AC$E3$82$A4)
  (88
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\Local
Folders\\Trash.msf)(89=104)(8A=$E3$81$94$E3$81\
$BF$E7$AE$B1)(8B
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\Local Folders\\Unsent Messages.msf)(8C=804)
  (8D=$E6$9C$AA$E9$80$81$E4$BF$A1$E3$83$A1$E3$83$83$E3$82$BB$E3$83$BC$E3$82$B8)
  (8E
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\Local Folders\\)(8F=1c)(90=ffffffff)(91
    =$E3$83$AD$E3$83$BC$E3$82$AB$E3$83$AB$E3$83$95$E3$82$A9$E3$83$AB$E3$83$80)
  (92
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\$CB$E5$FC$B9h$D6$FA$CC\\Trash.msf)(93
    =C:\\Documents and Settings\\*****\\Application Data\\Thunderbird\\Profile\
s\\i3y2qca0.default\\Mail\\$CB$E5$FC$B9h$D6$ED$B0\\)(94
    =$E3$83$8B$E3$83$A5$E3$83$BC$E3$82$B9$E3$81$A8$E3$83$96$E3$83$AD$E3$82$B0)>
{1:^80 {(k^81:c)(s=9)} 
  [1(^82^80)(^83^81)(^84=0)(^85=0)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^84)]
  [2(^82^85)(^83^86)(^84=0)(^85=0)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^87)]
  [3(^82^88)(^83^89)(^84=0)(^85=0)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^8A)]
  [4(^82^8B)(^83^8C)(^84=0)(^85=0)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^8D)]
  [5(^82^8E)(^83=1c)(^84^90)(^85^90)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^91)]
  [6(^82^92)(^83^89)(^84=0)(^85=0)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^8A)]
  [7(^82^93)(^83=1c)(^84^90)(^85^90)(^86=0)(^87=0)(^88=0)(^89=0)(^8A=)
    (^8B^94)]}

@$${1{@
@$$}1}@

@$${2{@
@$$}2}@

@$${3{@
@$$}3}@

@$${4{@
@$$}4}@

@$${5{@
@$$}5}@

Updated

14 years ago
Attachment #169732 - Attachment is obsolete: true

Comment 5

14 years ago
Created attachment 169735 [details]
panacea.dat with garbled folder RSS account

Sorry, I miss uploaded file in #3 and #4 was miss-operation too.
https://bugzilla.mozilla.org/attachment.cgi?id=169732
was the file with en-US rss.rdf (not garbled). Please ignore it.

This file (same as content of #4) is created with ja-JP localized rss.rdf.
Garbled folder seemed to be registerd correctly.
Acctually the account with garbled name folder encounters with no trouble
as long as I and my peer tested on WinXP and Linux. We can receive feeds,
delete them, move, filter... correctly with the account.
We can change the rss.rdf after the creation of the account too.
Even when I detele the rss.rdf, I can download feeds with the account.

That is, the only thing we should fix is the code which will create
(and register) the account folder according to the rss.rdf.

Comment 6

14 years ago
Created attachment 169737 [details]
ja-JP localized rss.rdf (rss.hostName is not localized)

Now, I found the way to localize "News & Blogs" in Thunderbird UI and at the
same time to make "News & Blogs[-n]" directory for RSS accounts.

acctNamePageValidate() method is used to determine the directory name.
http://lxr.mozilla.org/aviarybranch/source/mailnews/base/prefs/resources/content/aw-accname.js#42

The function use "rss.hostName" as a base of the directory name.
http://lxr.mozilla.org/aviarybranch/source/mail/extensions/newsblog/rss.rdf#8
It seems that rss.hostName is not used for Thunderbird UI. When I localize
rss.accountName, rss.wizardShortName and rss.wizardShortName but rss.hostname,
All UI seems to be localized correctly and created account directory will have
the name "News & Blog[-n]".

This attachment is the localized rss.rdf but only the value of rss.hostName
is not localized.
That is, localizers should localize rss.rdf too but keep rss.hostName.

IMHO: I think we should change the account directory for RSS account too same
as other accounts...
(Reporter)

Comment 7

14 years ago
*** Bug 276219 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: mscott → jshin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

13 years ago
This problem still reproduces.
Tb 1.8branch build 1.5 (20051025)
(Reporter)

Updated

13 years ago
Blocks: 313525
QA Contact: rss

Updated

10 years ago
Assignee: jshin1987 → smontagu

Comment 9

10 years ago
I'm not sure I understand what this bug is about. Is it really different from bug 313525? That is now resolved on trunk, and I assume this too, as the folder name isn't localizable anymore.
Assignee: smontagu → nobody

Comment 10

10 years ago
Hiro: please see comment 9.
Whiteboard: [gone with bug 313525?]

Comment 11

9 years ago
(In reply to comment #10)
> Hiro: please see comment 9.

Magnus, iirc Hiro is not around anymore.
duping
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 313525

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.