Win32 zip file is corrupt

RESOLVED WORKSFORME

Status

Calendar
General
--
blocker
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Surojit Niyogi, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I can't even test the 12-17 build because upon extracting, the zip file is
corrupt and says "Error in zip structure".  Please fix this so I can test and
report back!  

 

Reproducible: Always

Steps to Reproduce:
1. Download Win32 build
2. Try to extract
3. It will fail!

Actual Results:  
Nothing.  The zip extract fails

Expected Results:  
Extracted.

Comment 1

14 years ago
I assume you are talking about
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/2004-12-17/Sunbird-win32.zip

I am not able to reproduce this problem.  It unpacks and runs fine for me.  I
unpacked using unzip.exe from info-zip.org

I did notice it seems to immediately return if run from the command line,
mysteriously producing no window and leaving a sunbird.exe process running.  But
it seems to run ok if I double click on it from windows explorer.
Summary: Win32 zip file is corrupt → Win32 zip file is corrupt

Comment 2

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> 
> I can't even test the 12-17 build because upon extracting, the zip file is
> corrupt and says "Error in zip structure".  Please fix this so I can test and
> report back!  
> 
>  
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Download Win32 build
> 2. Try to extract
> 3. It will fail!
> 
> Actual Results:  
> Nothing.  The zip extract fails
> 
> Expected Results:  
> Extracted.

(In reply to comment #1)
> I assume you are talking about
>
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/2004-12-17/Sunbird-win32.zip
> 
> I am not able to reproduce this problem.  It unpacks and runs fine for me.  I
> unpacked using unzip.exe from info-zip.org
> 
> I did notice it seems to immediately return if run from the command line,
> mysteriously producing no window and leaving a sunbird.exe process running.  But
> it seems to run ok if I double click on it from windows explorer.
> 

I have the same problem as Mostafa;
I've tried a lot of things, and the conclusion is,
there's something wrong with that file!
Some compression software can unzip it, some others can't...

Best regards,
Andre

Comment 3

14 years ago
(The reporter was Surojit, not Mostafa.)

There are several possible causes, including:
  a. the file is corrupt
  b. the file was corrupted in transit
  c. some decompression tools have bugs

I did not have problems, so that throws doubt on (a).

If you think the problem is the file rather than the transmission or the
decompression tools, please provide specific instructions on how to reproduce
the problem, including exact text of any error messages.  I tried following the
vague instructions given and was unable to reproduce the problem.
gekacheka:
Is there an equivalent of md5sum we can run on Windows to check the signature of
the zip file in question?

Comment 5

14 years ago
There are programs able to generate an MD5 under Windows. Google for 'MD5 
Windows' (without quotes) or check out UltraEdit32, a quite good text editor 
which can also generate checksums.

Comment 6

14 years ago
Reporter,
I've downloaded and successfully installed all of the latest builds for windows
on Firefox, Thunderbird, and Sunbird, and none have been corrupted.  I suspect
this issue has been resolved.  Are you still experiencing this problem with the
latest files?  If not, please mark this bug resolved.

Comment 7

14 years ago
Marking Worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.