VersionCheck.php returning broken RDF for updates and maxVersion checks

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
13 years ago
2 years ago

People

(Reporter: Rui Afonso, Assigned: alanjstr)

Tracking

x86
Windows XP

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
When trying to install the Mouse Gestures extension on FireFox 1.0 I'm getting a
dialog box with the following text:
- begin of quote
Mouse Gestures 1.0 could not be installed because it is not compatible with this
version of FireFox.
(Mouse Gestures 1.0 will only work with FireFox versions from 0.8 to 0.10)" 
- end of quote
The extension link is:
"http://ftp.mozilla.org/pub/mozilla.org/extensions/mouse_gestures/mouse_gestures-1.0-fx+mz+tb.xpi"

Take good notice of the 0.10 version. Easy bug :)

Hope that helps
(Reporter)

Comment 1

13 years ago
Created attachment 169768 [details]
Error dialog box

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Extension/Theme Manager → Listings
Ever confirmed: true
Product: Firefox → Update
Version: 1.0 Branch → 1.0
Must be missing a main.type in the db, because the return from version checking
gives

<RDF:Description about="urn:mozilla::{FFA36170-80B1-4535-B0E3-A4569E497DD0}">

with just :: where it should be :extension:
Assignee: bugs → nobody
QA Contact: bugs → mozilla.update
No, on second look VersionCheck.php must be broken: everything I could find by
looking for things old enough to probably need to look for a higher maxVersion
fails the same way, with defective RDF:

Web Developer 0.8 {c45c406e-ab73-11d8-be73-000a95be3b12}
Magpie 3.1.2 {03786077-1aa1-45a6-81cf-da5b82b29919}
Image Zoom 0.1.7 {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
Paste Quote 0.3 {1C7CCF7A-ECB8-4CE5-B5D1-A4FA477A7242}

All have urn:mozilla:: in RDF that would otherwise say they are okay for 1.0.
Assignee: nobody → psychoticwolf
Severity: blocker → major
Component: Listings → Web Site
Summary: Mouse Gestures 1.0 extension can't be installed on FireFox 1.0 → VersionCheck.php returning broken RDF for maxVersion checks
(Assignee)

Updated

13 years ago
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Component: Web Site → Listings
(Assignee)

Comment 4

13 years ago
We lost "main.type AS exttype" from the SELECT statement.  Easy fix.  Patch
coming up.
http://lxr.mozilla.org/mozilla/source/webtools/update/update/VersionCheck.php#216 
Status: NEW → ASSIGNED
(Assignee)

Comment 5

13 years ago
Created attachment 169806 [details] [diff] [review]
Adds exttype back to the select statement.
(Assignee)

Comment 6

13 years ago
*** Bug 276346 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Not restricted to version checks - extension update silently fails, too.
Summary: VersionCheck.php returning broken RDF for maxVersion checks → VersionCheck.php returning broken RDF for updates and maxVersion checks
Checking in webtools/update/update/VersionCheck.php;
/cvsroot/mozilla/webtools/update/update/VersionCheck.php,v  <--  VersionCheck.php
new revision: 1.4; previous revision: 1.3
done

(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.