Closed Bug 276318 Opened 16 years ago Closed 16 years ago

Context menu search does not obey "browser.tabs.loadInBackground" pref (tabs are not selected)

Categories

(Firefox :: Search, defect)

defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox1.5

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

Attachments

(1 file, 1 obsolete file)

The pref is supposed to be checked at:
http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#2409

but the pref variable is not defined. Patch coming up.
Attached patch Patch (obsolete) — Splinter Review
Attachment #169800 - Flags: review?(mconnor)
Status: NEW → ASSIGNED
(In reply to comment #0)
> but the pref variable is not defined.

It seems that gPrefService is defined as expected.
http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#696
Attached patch Patch 2Splinter Review
Major oopsies :). That was a little presumptuous of me wasn't it? Thanks to
Callek and Torisugari for pointing out my mistake.
Attachment #169800 - Attachment is obsolete: true
Attachment #169801 - Flags: review?(mconnor)
Attachment #169800 - Flags: review?(mconnor)
Attachment #169801 - Flags: review?(mconnor) → review+
Whiteboard: [patch-r+] [checkin needed]
Target Milestone: --- → Firefox1.1
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.375; previous revision: 1.374
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Whiteboard: [patch-r+] [checkin needed]
Status: RESOLVED → VERIFIED
*** Bug 251777 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.