Anti-ads blocker improvement

VERIFIED DUPLICATE of bug 94035

Status

()

Firefox
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 94035
14 years ago
12 years ago

People

(Reporter: Fred, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
It would be nice to have the following:

pop-up blocker was nice, but there is other kinds of annoying things.
Especially, flash content that overlaps a webpage,
banners and similar.

From a given web page right click... select block
and have a list of fetched url domains
and then block such web content.

Blocking specific "script,object,embed,img,a href" section would be nice also.



for instance, http://ads.xxxx.com/ads/content.php?src=...'

Meaning that firefox should not download any content from there, unless 
unblocked from now on, wether it is:
text, flash, images, video, music or anything else.
putting a placeholder download link red box - [blocked]
instead which can be downloaded if you click on it.

For instance, a user might want to see:

http://my.com/content.swf

but not:
http://my.com/banner.swf
http://my.com/intro.wav


It saves some bandwidth on slow connection and it avoids 
seeing unwanted and undesired ads or content.

Of course the block should be sorted by subdomain, path, file, file type.
Even using Regexp blocking would be nice if possible.
Such that one could discriminate at various degree 
globally or only for a given site.

One way before was to not have the flash player, 
but that doesn't always work
since some website really needs flash.

Sincerely yours,
Fred

*** This bug has been marked as a duplicate of 94035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.