If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onmouseout does not fire when mouse enter a link from below

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Ivan Wills, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
When the mouse cursor enters a link (which is surrounding an image) from below
the onmouseout event does not fire if the cursor leaves from another edge (ie
not the bottom). Entering from all other edges seem to work. The onmouseover
event is working correctly
(Reporter)

Comment 1

13 years ago
Created attachment 169857 [details]
Example of the bug in action (move cursor over top menu from below to see)
Please file DOM bugs against the right component.  The JavaScript Engine has
nothing to do with onmouseout firing, it's an implementation of the ECMA-262
Edition 3 language, not of any w3c or de-facto DOM spec.

/be
Assignee: general → general
Component: JavaScript Engine → DOM: Events
QA Contact: pschwartau → ian
Reporter, what build are you using?  This worksforme with a current Linux GTK1
trunk build...
(Reporter)

Comment 4

13 years ago
I am using Firefox 1.0 on Mandrake 10.0 in Gnome but I also noticed the problem
on Mozilla 1.6 Mandrake 10.0 in KDE (a different computer)

Ivan
Is that a GTK1 or GTK2 build of 1.6?  For that matter, could you try a current
trunk build of either Firefox or Mozilla?  It's been 9 months since Firefox 1.0
branched....
(Reporter)

Comment 6

13 years ago
It was a GTK2 mozilla build.
I tried the nightly build 'Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6)
Gecko/20050106' and the bug does not appear to be there. So I guess there is no
problem (I will check the nightlies in the future).

Thanks
Marking worksforme per comment 6.  Thank you for testing that nightly, Ivan!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.