Add Cut/Copy context menu items for downloaded items in the download manager

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: Földényi Tamás, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

You should add cut / copy context menu items for downloaded files in the
donwload manager in order to easily copy / move that file on platforms like
Windows or Mac.

Now if you want to do that you should first click on the 'download folder'
button to see icons where you can perform the desired operation. This is
unnecessary, if you just want to use the cut or copy menuitem on that.

Download Manager, and the icons' look and feel remind people the icons where
they can perform this operation, so they expect these menu items.

I guess only small number of users copy / move files in this way, but these
probably can't do it in a different way. Actually since FF doesn't ask where to
place my downloaded files, I've began to move/copy files with mouse, because
many applications such as Total Commander can paste files this way: Total
Commander is always loaded, Download Manager is always at hand, so copying /
moving is very comfortable in this way.

btw may it's an other bug, but drag and drop could also work...

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

13 years ago
Severity: normal → enhancement

Updated

12 years ago
QA Contact: ali → download.manager
Assignee: bugs → nobody
Not sure how feasible this is, but confirming as feature request...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Sorry, but I just don't see this being something we want to do.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.