CSS Property for <a> tag is being ignored by firefox, but not by IE

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: syipisa, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
hi good guys,

i am using css on an <a> tag to make it appear almost like a form-button. 
everything works fine, the <a href="#" class="navigation">link</a> looks like a 
button and even has the 3D-effect (border-style:outset and inset when active). 

unfortunately there is an attribute which has no effect on firefox but on IE 
which is "width". i dont know if css-standards allow this property, but it 
would be very nice if you would implement it.

greetings
syipisa

Comment 1

13 years ago
'width' does not apply to non-replaced inline elements like <a>.
http://www.w3.org/TR/CSS21/visudet.html#propdef-width

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

13 years ago
excuse me but who said that <a> is a non-replaced inline element ...besides.... 
what the hell is that...

i just know that its very useful, obviously you are able to apply other 
properties like border and background....e.g. you can make a nice formatted 
element of <a>....the only thing that i am missing is that damn width value...

i dont want to tell people that this site is optimized for IE :-(
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
The CSS spec says its a non-replaced inline element, actually.  So width should
not apply to it.  Read the links, and http://bugzilla.mozilla.org/etiquette.html
as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
Quote from your etiquette:
> "Open Source" is not the same as "the developers must do my bidding." 

that would be an extreme....but the other one would be "i dont care at all what 
your bidding is" ....e.g. i look in css spec and smash your request in your 
face...instead of thinking more about how reasonable your request is...
well i think the right answer would be we will think about it and contact w3 or 
something...

Another quote:
> if committed enough times they will cause those contributors to demand the 
disabling of your Bugzilla account.

go on...disable my damn account, i wont use it again anyway. instead i'll be 
telling all people that its still too early to change to mozilla and that they 
should proceed using the bloody monopoly browser...because they DO give a damn 
about what their users prefer. and believe me, as a longtime software- and web-
developer they care about what i say.

cya.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
What's the point of having a CSS standard if we don't follow it?  Our entire
goal as an organization is to push for standards-compliance, in order for the
browser to become a non-issue on the web.  If the standard explicitly says X
doesn't apply to that type of element, that's cut and dried.  Saying the spec
should be ignored really ignores the entire point of standards compliance
(namely that content should "just work" in any compliant UA).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.