The location bar freezes and cannot accept focus.

RESOLVED DUPLICATE of bug 91536

Status

SeaMonkey
Autocomplete
--
major
RESOLVED DUPLICATE of bug 91536
14 years ago
13 years ago

People

(Reporter: Amos Kariuki, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
The location bar freezes and cannot accept focus.

Steps to Reproduce:
1. Type an URL address with a previous history in the location bar such that the
autocomplete history window pops up.
2. Using the keyboard bring up the file menu (I'm using Win XP so <ALT>-'Down
arrow' would do) such that both the file menu window and the autocomplete
history window pop-up are open.
3. Click on any address in the autocomplete history window.

Actual Result: Both pop-up windows close and the browser does not navigate to
expected URL selected. The location bar also become completely unsuable and
cannot attain input focus.

Expected Result: Browser navigates to expected URL.

Bug reproduced on both firefox 1.0 and mozilla 1.7.5.

Updated

14 years ago
Severity: normal → major

Comment 1

14 years ago
Confirmed, but there's more.  Clicking the drop-arrow on the address bar works
fine, but the text area won't focus (or select) at all.  When I give the comment
box here focus and hit "c" the box loses focus, and no character is typed -- but
only if it's the first character in the box.  When that happens, the cursor is
able to navigate up and down the page as though it were in edit mode.

If I then give focus to another application and come back, everything works fine
again.

Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041221
Firefox/1.0+

Comment 2

14 years ago
I also see this problem with Mozilla 1.8a6 (Gecko/20050111).
This is a duplicate of a bug on not having the autocomplete and main menus open
at once....  Please find that and mark this duplicate.
Whiteboard: DUPEME

Comment 4

14 years ago
Maybe a duplicate of bug 244857 and/or bug 91536?

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 91536 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.