page not printed properly ( because of <br clear="left">)

RESOLVED DUPLICATE of bug 220102

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 220102
13 years ago
13 years ago

People

(Reporter: zohar, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041221 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041221 Firefox/1.0+

In the demonstrated URL, the page looks fine, but when printing it, and when
looking at the "print preview", only a part of iy is displayed.

Reproducible: Always

Steps to Reproduce:
1.go to the URL
2.preview the print
3.print

Actual Results:  
only a part of the page is printed - some parts are missing

Expected Results:  
the printing should contain everything that is shown on that page.

Comment 1

13 years ago
Over to Printing.
Assignee: firefox → core.printing
Component: General → Printing
Product: Firefox → Core
QA Contact: firefox.general
Version: unspecified → Trunk

Comment 2

13 years ago
Lots of stuff missing from the url also in print preview with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041229
Firefox/1.0+
Several other bugs mention similar problems: 220102, 136826, 232880

Comment 3

13 years ago
*** Bug 276740 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20050101

If I remove this: 

<br clear="left"><br clear="left"> 

all is well. All before gets printed as long as it fits on the first 2 pages,
all thereafter is printed on the 3rd page.
I made a local copy of the files, saved as webpage complete, did delete all
script, as script wasn´t needed to show the bug, and started commenting out.
I succeeded getting the top half of an image printed at the bottom of the second
page, but it didn´t continue at the third page. When I deleted the preceding
image, it was printed fully.

stylesheets:
http://i.cmpnet.com/mobilizedsoftware/layout.css
http://i.cmpnet.com/mobilizedsoftware/fonts.css

I don´t see similarities to the following bugs:
Bug 220102 Displayed page vs. Print and Print Preview: Missing DIV section lines
Bug 136826 Main document text disappears in print preview/print
Bug 232880 Print and Print preview not including page content, mostly just headers
Summary: page not printed properly → page not printed properly ( because of <br clear="left">)

Comment 5

13 years ago
Dupe of 
Bug 220102 Displayed page vs. Print and Print Preview: Missing DIV section lines

see testcase over there, same cause <br clear="left">

*** This bug has been marked as a duplicate of 220102 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.