Mouseover and Clicking on image rollover links quickly and possibly before page loads produces function not defined errors

RESOLVED DUPLICATE of bug 252542

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 252542
14 years ago
5 years ago

People

(Reporter: Matthew Schultz, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122

If I mouseover and click around on navigation links at the top with speed,
javascript will produce an error for both the mouseover and mouseout functions
saying they are not defined despite them being defined and the source file
pointing to that file in the head before the functions are used.  I also
sometimes get the error that the function is not defined and the source file
reads: javascript:alert('TODO:FIXME') Line: 0
I also tested this with an external javascript file and it seems to produce the
same errors more often in this case.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to website listed
2. Quickly click on the different navigation links at the top while the page is
loading or before it has loaded and repeat until you get a javascript error.

Actual Results:  
-Mouseover/Mouseout functions produced a function not defined error.
-Sometimes the source file reads: javascript:alert('TODO:FIXME') Line: 0

Expected Results:  
No Errors as the function is defined before it is called.
This is a duplicate of the bug on event handlers not getting cleared when the
window scope is cleared...
Whiteboard: DUPEME
(Reporter)

Comment 2

14 years ago
What's the bug number?  I'd like to track the already established one.
Version: unspecified → Trunk
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
I'm thinking I reported what seems like the same bug again with bug 296260.
Component: General → JavaScript Engine
Depends on: 296260
Product: Mozilla Application Suite → Core
Version: Trunk → 1.8 Branch

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 252542 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.