Closed Bug 276535 Opened 17 years ago Closed 17 years ago

unable to fill form inputs

Categories

(Core :: XSLT, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 236596

People

(Reporter: atbest, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Unable to fill fomr inputs in some cases. When this bug appears, we have to
change window (from firefox to an other one, like open office by example), and
to switch back to the firefox window, and here, we are able to fill the
displayed form.

Reproducible: Always

Steps to Reproduce:
1. Follow my link
2. If you are able to fill the form, just swith window (from firefox to an other
one), and switch back again to firefox), and "normally" you are now unable to
fill the form :/
3. To be able to fill the form, switch to an other window and sitch back to firefox.

Actual Results:  
...

Expected Results:  
...
I too have this problem, but only when the page is generated by the application
of an xslt transform to an xml document.
I have the exact same problem when the page is generated by the application
of an xslt transform to an xml document.
This reliably causes the problem within a couple reloads.

FILE: test.xml
===============================

<?xml version='1.0' encoding='ISO-8859-1'?>
<?xml-stylesheet type='text/xsl' href='test.xsl'?>
<foobie>
        <input style='text'/>
</foobie>


FILE: test.xsl
===============================

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
        <xsl:output method="html" indent="yes"/>
        <xsl:template match="*|@*|processing-instruction()|comment()">
                <xsl:copy>
                        <xsl:apply-templates
select="*|@*|text()|processing-instruction()|comment()"/>
                </xsl:copy>
        </xsl:template>
        <xsl:template match="foobie">
             <html>
                    <body>
                          Type here: <xsl:apply-templates/>
                    </body>
             </html>
        </xsl:template>
</xsl:stylesheet>
 
ON:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

*** This bug has been marked as a duplicate of 236596 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Component: Form Manager → XSLT
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.