Download freezes, may require hard kill of Mozilla

RESOLVED DUPLICATE of bug 142664

Status

()

RESOLVED DUPLICATE of bug 142664
14 years ago
10 years ago

People

(Reporter: mpickhardt, Assigned: bugs)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Configuration is as follows:  Windows/XP Home edition version 2002, SP2.  One
primary hard  drive (C:).  Several CD-ROM, CD-RW, and DVD-ROM hard drives, plus
a USB connected removable hard drive (H:).  Files are frequently downloaded to
both the primary hard drive and to the removable hard drive (C: and H:).

If I attempt to download a file and override the default destination by entering
a fully pathed file name in the "File name" field of the "Save as" panel, and
the default desination is on the primary drive AND the removable drive is not
plugged in, the download will hang.  The Windows "No disk" panel will appear
offering the choices of "Cancel", "Try again", and "Continue".  Regardless of
which is selected, the machine will make the "bloop" noise, the panel will
disappear and immediatly re-appear, and nothing else happens.  This state will
continue indefinately.  Options are to A) bring up task manager and cancel
Mozilla (which still requires that one of the "No Disk" buttons be punched), or
B) insert the removable drive (if available) and press one of the buttons.  Side
note:  If option B) is selected, the download will continue regardless of which
button is pressed.

It appears that the download manager is attempting to access all drives in it's
recent download list even if a fully pathed filename is specified as the
download target.  Furthermore, it does not handle errors in this situation
gracefully.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 142664 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.