Firefox disk image should use .dmg internal zlib-compression, not .dmg.gz

VERIFIED DUPLICATE of bug 242845

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 242845
13 years ago
13 years ago

People

(Reporter: Ali Ebrahim, Assigned: Brian Ryner (not reading))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Firefox version of bug 268074 (bits and pieces of comment 0 stolen from there).

Firefox on Mac OS X uses a .dmg.gz format for distribution. This is a regular
non-compressed .dmg compressed using gzip. Instead, we should be using the .dmg
format's zlib-compression feature. According to this man page:

http://developer.apple.com/documentation/Darwin/Reference/ManPages/man1/hdiutil.1.html

compressed .dmg archives have been supported since MacOS X 10.1. Since we
require 10.1 or newer in order to run Firefox, theoretically there should be no
problem with regards to backwards compatibility. .dmg files are also the
standard method of software distribution on Mac, so we also adhere to platform
standards, and avoid the unlikely problem case where a user may not have Stuffit
Expander installed to open the .gz.

This has to be two steps process any way:

1. Create disk image and copy Firefox there
2. Apply compression, what is acomplished with command:

hdiutil convert tmp-firefox-1.0.en-US.mac.dmg \
   -format UDZO -o firefox-1.0.en-US.mac.dmg \
   -imagekey zlib-level=9

Key things are: "-format UDZO" set disk image format to compressed one;
"-imagekey zlib-level=9" set maximum compression level for gzip/zlib.

man hdiutil for more information.

This has also been discussed here at some length by various commenters:
http://blog.ebrahim.org/archives/2004/12/30/mac_firefox_install_problems.php
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 242845 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
verifying own dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.