rightclicking in listbox is being interpreted as both left click and right click

VERIFIED FIXED in M15

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: mik, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bug Helper:
User-Agent: Mozilla/5.0 [ru-RU.KOI8-R] (Linux; I)
BuildID:    2000012520
When right-clicking on a listbox (no matter open or closed) it also
gets a left-click, i.e. it opens or selects something.  And rignt click
itself goes to underlaying object. (the same for the buttons)
Also rightclicking in a input area (textarea) does not whows context menu, only
changes cursur's shape (as if menu were open)
Reproducible: Always
Steps to Reproduce:
1. open page with inputs
2. rightclick on a listbox or on a inputline
3.

Actual Results:  page's context menu is being displayed for listbox
or no menu is displayed for inputline
Expected Results:  list box'es context menu or no menu at all (rightclick ignored)
or textarea's context menu

Looks like listbox simply lets right click go further.
Textarea actually tryes to display menu, but fails.
Buttons behave exactly like listboxes.

Comment 1

19 years ago
Reassigning to Rod.
Assignee: karnaze → rods
(Assignee)

Comment 2

19 years ago
setting to M15
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 3

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 5

18 years ago
verified on build 2001-08-07-80-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.