addons.update.mozilla.org thinks I've got another Firefox version

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Nate, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
I'm running Firefox 1.0 on Windows XP.  This particular install has been
upgraded mulitple times (0.7, 0.8, 0.9, 1.0, etc).

Steps to reproduce:

1) Open Extension Manager from Firefox's Tools menu.
2) Click "Get More Themes link".  For me this opens a Firefox window with the
url
https://addons.update.mozilla.org/themes/?application={ec8030f7-c20a-464f-9b0e-13a3a9e97384}.
3) Click on any of the links on the home page's body. I click on the link to the
Qute theme. This openned the url
https://addons.update.mozilla.org/themes/moreinfo.php?application=firefox&version=0.9.0+&os=Windows&id=7.

Notice the URL in step 3) refrences firefox version 0.9.0. I'm not sure if its
firefox sending the wrong browser version or if the website's code.

This bug causes the following side affect:

Qute version 2.1.3 works on Firefox 0.9.
Qute version 3.0 works on Firefox 1.0.

Now, because the site is redirecting me to the 0.9.0 version of the Firefox
themes, the "Install Now" link for the Qute theme references Qute version 2.1.3.
 When I try to install this version, I get an error telling me that this theme
doesn't work with Firefox 1.0.  If I change the 0.9.0 parameter in the URL to
1.0 and refresh the page, the "Install Now" link now references Qute version 3.0
as expected.
check about:config and make sure app.extensions.version is set to the default. 
We key off that pref, which allows override/testing, but should be 1.0 if you're
using 1.0
(Reporter)

Comment 2

14 years ago
app.extensions.version seems to be okay... it is set to "1.0".
(Reporter)

Comment 3

14 years ago
I tried to reproduce this bug with the Theme manager today and was unable to
reproduce. Very weird.

I tried to follow the same steps with the Extension Manager and got similar
results to my original problem.

"Get More Extensions" link points to
https://addons.update.mozilla.org/extensions/?application={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

But if I click on any of the links on this page, I get URLs like the following:

https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=0.10.1&os=Windows&id=383

Notice the firefox version in the URL parameter is "0.10.1".

Note: I'm using the same machine as in my original comment.

I'm very confused now. This "bug" doesn't seem to happen all the time.
(Reporter)

Comment 4

14 years ago
I tried some more debugging:
1) Tried exiting out of Firefox completely. Still broken
2) Exited out of Firefox completely and suspended the machine. Woke up the
machine and problem is gone.

I'm not sure what exactly fixed the problem, but I can no longer reproduce this
issue.

Comment 5

14 years ago
I think UMO extracts version information from the UA string. Do you have any
extensions like UA switcher? Was general.useragent.vendorSub set to 1.0?

Works for me, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0. Does it always work for you now?
(Reporter)

Comment 6

14 years ago
I'm not running a UA switcher. general.useragent.vendorSub is set to 1.0.

This particular box has had Firefox upgraded multiple times. Right now I'm
thinking that the extension/theme home page was probably cached in the browser's
cache. Of course this would only be a valid line of thinking if the URLs for
"Get more themes" and "Get more extensions" are the same between versions.

(In reply to comment #5)
> I think UMO extracts version information from the UA string. Do you have any
> extensions like UA switcher? Was general.useragent.vendorSub set to 1.0?
> 
> Works for me, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
> Gecko/20041107 Firefox/1.0. Does it always work for you now?

Comment 7

14 years ago
yes, the link is not changed betweeen the versions. Strange it cached the page
though.

Marking WFM, but if you have more ideas or it happens again (not due to cache),
feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.