Get all new messages ignores pop3 accounts

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
14 years ago
14 years ago

People

(Reporter: wsheets, Assigned: sspitzer)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041230
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041230

This started about the last week of December.  'Get all new messages' used to get
messages from my two imap accounts plus my pop3 account.  Now it gets only the
imap accounts.  No attempt is made to contact the pop3 server until I do it
manually.

Reproducible: Always

Steps to Reproduce:
1.Have both imap and pop3 accounts defined.
2.Click 'Get all new messages'
3.Note that the pop3 server is never contacted

Actual Results:  
Imap accounts are fetched.

Expected Results:  
Get pop3 mail also.
Confirming bug - this happens on my trunk build. Output on console as follows:

GetMessagesForInboxOnServer uri = imap://***@***.com
GetMessagesForInboxOnServer uri = imap://***@***.com
WARNING: Declared InterfaceInfo not found, file xptiInterfaceInfo.cpp, line 434
[Exception... "Cannot find interface information for parameter arg 2
[nsIPop3IncomingServer.downloadMailFromServers]"  nsresult: "0x80570006
(NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame ::
chrome://messenger/content/mailWindowOverlay.js ::
GetMessagesForAllAuthenticatedAccounts :: line 1989"  data: no]

Obviously the imap accounts are fine, but when fetching the pop mozilla isn't
happy. A single click on the Get Msg button for the pop account  works fine.

My Build id:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041231
Status: UNCONFIRMED → NEW
Ever confirmed: true
Sorry, forgot to mention I'm not using the global inbox feature - all my
accounts  are viewed seperately.
Keywords: regression
(Reporter)

Comment 3

14 years ago
Hmpf.  After spending half a day checking out sources from various dates and
trying to figure out which commit caused this bug -- I finally deleted my
src directory and started from scratch.

After that, I found that I could not reproduce the bug, even with sources as of
02Jan2004 00:30 GMT.

I conclude that my bug was an artifact of recent changes to client.mk combined
with stale object files.

Mark, what about you?
After clean rebuild, WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6)
Gecko/20050102.

Walter, I think we can close this as WFM now? I think you're probably right
about it being a problem with the recent build changes.
(Reporter)

Comment 5

14 years ago
Yes, this can be closed, thanks.
Resolving as WFM as both reporter & confirmer are happy that it is.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.