Pressing 'enter' caused bug to be submitted prematurely

VERIFIED INVALID

Status

()

Bugzilla
User Interface
--
trivial
VERIFIED INVALID
13 years ago
5 years ago

People

(Reporter: Doug Hockin, Assigned: myk)

Tracking

Details

(Reporter)

Description

13 years ago
In the new version of bugzilla for Thunderbird, I hit an 'enter' and it
submitted the bug before I had finished entering all the fields.  This is a
really serious problem.

Problems should never be submitted until the "Commit" button is explicitly
pushed.

Comment 1

13 years ago
what browser were you using? this is a browser 'feature' for the most part.
Assignee: asa → myk
Component: Bugzilla: Keywords & Components → Creating/Changing Bugs
Product: mozilla.org → Bugzilla
QA Contact: timeless → mattyt-bugzilla
Version: other → 2.19.1
This is a feature of your browser, and almost every browser does it.

Pressing enter while in a form field submits the form.  It's always been that
way, and there's no way to stop it without tons of hacky javascript.

I'm not sure I want it fixed, personally...  I actually make use of that to
avoid having to scroll around to find the submit button :)
Status: UNCONFIRMED → NEW
Component: Creating/Changing Bugs → User Interface
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Future
Severity: major → trivial
(Assignee)

Comment 3

13 years ago
Yeah, this is a feature, not a bug, although perhaps browsers should (or already
do) allow you to disable it, and Bugzilla might consider allowing you to clean
up more of the damage from premature submission than it currently does (i.e. by
letting you edit the bug description).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Future → ---

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.