Page "scrolls" while loading (many) images.

RESOLVED DUPLICATE of bug 60307

Status

()

defect
RESOLVED DUPLICATE of bug 60307
15 years ago
11 months ago

People

(Reporter: pepe, Assigned: roc)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

* TITLE/SUMMARY
Page "scrolls" while loading (many) images.

* STEPS TO REPRODUCE
1) go to a page with many images(without given height attribute) and scroll down
_while_ they are loading. 
Testpage: http://home.arcor.de/pepe79/testpage/testpage.html
2) stop scrolling and remember the position where you are on the page (e.g.
number of image when they are numbered) still _while_ loading!
     
* RESULT
While images load which lie above scroll position, they push the content under
them down. Thats correct because of missing height attribute. But the scroll
position does not adapt to this. 
e.g. You scroll to label of image number 50 at the top, but when all images are
loaded, you look at image number 17.

 - What was expected
The text at the top of the scrollwindow, should not move down because of loading
objects which lie above the text.

*Tested with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20050101 Firefox/1.0+
but does occur in older releases too...

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.