Filters: rules of searching strings disapear if using double-quote in the string searched.

VERIFIED INVALID

Status

Thunderbird
General
--
major
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: blue_wild_sea, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Thunderbird 1.0   Productversion  1.7.5: 2004122606

just do as follow:
type a new filter, based on searching in the bodies of mail the string:
.exe
it works fine.
Close Reopen Thunderbird, Close Reopen... it wil work fine until the end of time.

Now do the following, cancel every filters o take a brand new machine and
install thunderbird.
just do as follow:
type a new filter, based on searching in the bodies of mail the string:
.exe"
See the double-quote, it is not written anywhere it is forbidden to use it
the filter is made, just close the windows one by one, till you close
thunderbird, take a break, reopen thunderbyte, reopen the filters, your filter
is still her, but inside the filter, there is no rule anymore, thunderbyte just
rember the actions to perform, but has eaten the rule itself, because of the
double-quote.



Reproducible: Always

Steps to Reproduce:
1. type a new filter, based on searching in the bodies of mail the string:
.exe"
See the double-quote, it is not written anywhere it is forbidden to use it
the filter is made, save it.
2. just close the windows one by one, till you close thunderbird,
3. take a break (not important) 
4. reopen thunderbyte,
5. reopen the filters, your filter is still her, but inside the filter, there is
no rule anymore, thunderbyte just rember the actions to perform, but has eaten
the rule itself, because of the double-quote.

Actual Results:  
Can't use the filter has i would like to. A lot of work to create lots of
filters and if one have a double quote, it is done for nothing, if you put more
than once double-quotes, it can do funny thing when the filter is written on
file and more funny when the file is read and interpreted to the filter windows

Expected Results:  
the rule imagined and typed for searching a string should not disappear, if some
ascii characters can not be used, forbid it with an alert when user is typing.
the rule should have been in front of me when reopennig thunderbird, and if so i
am sure it would have worked...


Filters are the reason why, someone use software that are pretty big, i have
software of 450KB working fine, but i have to put in directories myself and
cannot automate it. So it is a major function and thus a major severity issue.
(Reporter)

Comment 1

14 years ago
re-written in bug 276848
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.